View Issue Details

IDProjectCategoryView StatusLast Update
16139Bug reportsSurvey editingpublic2020-04-16 13:27
ReporterDanielZ Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.1.16 
Fixed in Version4.1.17 
Summary16139: Multiple Numeric Input Slider ignores Slider Initial Value but defaults to 5
Description

The slider version of the Multiple Numeric Input question type seems to ignore the inital value set in the configuration and always uses 5 as the default value.
See forum topic at https://www.limesurvey.org/forum/design-issues/120831-multiple-numerical-input-slider-default-value-5

Steps To Reproduce

1) Create a survey with a Multiple Numeric Input question
2) Add a subquestion
3) Activate "Use slider layout" on the slider tab
4) Set "Slider Initial Value" to something different than 5, e.g. 30
5) Open the survey preview

Additional Information

Apparently, the issue might relate to a variable name mismatch in https://github.com/LimeSurvey/LimeSurvey/blame/0c7ab87a49e33634528cb218ef732b3d232c0fab/application/views/survey/questions/answer/multiplenumeric/rows/sliders/answer_row.twig#L75
It uses "slider_value" which seems to be unset while "slider_default" contains the value set in the "initial slider value" configuration option.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.17+200414
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql
Server OS (if known)
Webserver software & version (if known)
PHP Version 7.2.29

Activities

DenisChenu

DenisChenu

2020-04-16 09:08

developer   ~57137

It uses "slider_value" which seems to be unset while "slider_default"

No because slider_value are not deaut when move previous.

But please : send a sample lss file ...

DanielZ

DanielZ

2020-04-16 09:26

reporter   ~57138

I just guessed based on my observation that slider_value is not documented as @var in the header while the documented @var slider_value is never used in the file.

Sample lss file is attached...

DenisChenu

DenisChenu

2020-04-16 12:44

developer   ~57144

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29838

lime_release_bot

lime_release_bot

2020-04-16 13:27

administrator   ~57151

Fixed in Release 4.1.18+200416

Related Changesets

LimeSurvey: master b37d36a0

2020-04-16 12:44:23

DenisChenu

Details Diff
Fixed issue 16139: Multiple Numeric Input Slider ignores Slider Initial Value
Fixed issue : Multiple Numeric Input Slider ignores slider_default_set
Dev: review and test whole with position and setPosition
Affected Issues
16139
mod - application/views/survey/questions/answer/multiplenumeric/rows/sliders/answer_row.twig Diff File
mod - assets/packages/questions/numeric-slider/scripts/numeric-slider.js Diff File

Issue History

Date Modified Username Field Change
2020-04-16 09:02 DanielZ New Issue
2020-04-16 09:08 DenisChenu Note Added: 57137
2020-04-16 09:26 DanielZ File Added: limesurvey_survey_361273.lss
2020-04-16 09:26 DanielZ Note Added: 57138
2020-04-16 11:53 DenisChenu Assigned To => DenisChenu
2020-04-16 11:53 DenisChenu Status new => assigned
2020-04-16 12:44 DenisChenu Changeset attached => LimeSurvey master b37d36a0
2020-04-16 12:44 DenisChenu Note Added: 57144
2020-04-16 12:44 DenisChenu Resolution open => fixed
2020-04-16 12:44 DenisChenu Status assigned => resolved
2020-04-16 12:44 DenisChenu Fixed in Version => 4.1.17
2020-04-16 13:27 lime_release_bot Note Added: 57151
2020-04-16 13:27 lime_release_bot Status resolved => closed