View Issue Details

IDProjectCategoryView StatusLast Update
16087Bug reportsSurvey takingpublic2020-04-14 12:53
ReporterJmantysalo Assigned ToDenisChenu  
PrioritynormalSeveritytweak 
Status closedResolutionfixed 
Product Version4.1.13 
Fixed in Version4.1.16 
Summary16087: Resume later -email seems ugly
Description

Here is an example of a mail one got when clicking "Resume later". There are no <P> nor <BR> in the mail.

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head>
Olet tallentanut keskeneräisen kyselyn. Voit palata kyselyyn käyttäen allaolevia tietoja. Säilytä tämä sähköposti, emme voi lähettää salasanaa sinulle.

HYVINVOINTIKYSELY 2020 - Työskentely koronaepidemian aikana

Nimi: Jori
. . .

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.13+200325
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMariaDB, newest available on Ubuntu 18.04 LTS
Server OS (if known)
Webserver software & version (if known)
PHP VersionNewest available on Ubuntu 18.04

Relationships

related to 16108 new Feature requests "Save survey" email text : usage isHtmlEmail of survey setting 

Activities

ollehar

ollehar

2020-04-03 15:35

administrator   ~56932

Please provide us with a screenshot of the error. Thank you.

Jmantysalo

Jmantysalo

2020-04-03 16:54

reporter   ~56934

A screenshot of my email program containing for example "Thank you for saving your survey in progress. The following details can be used to return to this survey and continue where you left off. Please keep this e-mail for your reference – we cannot retrieve the password for you. WELL-BEING SURVEY 2020 Name: Jori Password: mypass Reload your survey by clicking on the following link (or pasting it into your browser): https://survey.tuni.fi/limesurvey/index.php/survey/index/sid/452321/loadall/reload/scid/5/lang/en/loadname/Jori/loadpass/mypass ", i.e. an email without any newline?

cdorin

cdorin

2020-04-03 17:03

manager   ~56935

Olle, the HTML is "getting lost" when sending emails. Already aware of that

Thanks for report @jmantysalo !

DenisChenu

DenisChenu

2020-04-03 19:17

developer   ~56936

In 3.X it's an HTML or text email for save ?

Seems to be (here) a text email sent in HTML.

Jmantysalo

Jmantysalo

2020-04-04 07:52

reporter   ~56942

Sidenote, it is kind on un-orthogonal design that one can customize messages for invitation, reminder etc, but not the "resume later" -email.

DenisChenu

DenisChenu

2020-04-04 10:59

developer   ~56943

My opinion :

  • admin email must be moved to plugin
  • save system must be moved to plugin ...

;)

DenisChenu

DenisChenu

2020-04-07 17:06

developer   ~57009

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=29815

lime_release_bot

lime_release_bot

2020-04-14 12:53

administrator   ~57113

Fixed in Release 4.1.17+200414

Related Changesets

LimeSurvey: master dc5e05ac

2020-04-07 17:06:37

DenisChenu

Details Diff
Fixed issue 16087: Resume later email text bad content-type set
Dev: resume later are a fixed text, no use oh html setting of survey
Dev: leave text but force it as text
Affected Issues
16087
mod - application/libraries/Save.php Diff File

Issue History

Date Modified Username Field Change
2020-04-03 11:19 Jmantysalo New Issue
2020-04-03 15:35 ollehar Note Added: 56932
2020-04-03 16:54 Jmantysalo Note Added: 56934
2020-04-03 17:03 cdorin Note Added: 56935
2020-04-03 17:03 cdorin Priority none => normal
2020-04-03 17:03 cdorin Status new => confirmed
2020-04-03 19:17 DenisChenu Note Added: 56936
2020-04-04 07:52 Jmantysalo Note Added: 56942
2020-04-04 10:59 DenisChenu Note Added: 56943
2020-04-04 10:59 DenisChenu Assigned To => DenisChenu
2020-04-04 10:59 DenisChenu Status confirmed => assigned
2020-04-07 17:06 DenisChenu Changeset attached => LimeSurvey master dc5e05ac
2020-04-07 17:06 DenisChenu Note Added: 57009
2020-04-07 17:06 DenisChenu Resolution open => fixed
2020-04-07 17:07 DenisChenu Status assigned => resolved
2020-04-07 17:07 DenisChenu Fixed in Version => 4.1.16
2020-04-07 17:13 DenisChenu Relationship added related to 16108
2020-04-14 12:53 lime_release_bot Note Added: 57113
2020-04-14 12:53 lime_release_bot Status resolved => closed