View Issue Details

IDProjectCategoryView StatusLast Update
16073Bug reportsSurvey editingpublic2020-05-22 17:46
Reporterymca Assigned Tocdorin  
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version4.1.13 
Summary16073: Adding translation language to the survey
Description

In a survey that I've made I added a language translation.
Then saw a problem with a question that has answer of 249 countries that I made (I don't need to translate the list).
I fixed the problem with the list of countries and then saw the translation in the other language was empty (all 249 of them).
The only way that I could fix and make the English country list reappear, was to delete the added language (with all translations that have been made) and re-add it.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.12+200324
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Versionsame
Server OS (if known)
Webserver software & version (if known)
PHP Versionsame

Relationships

related to 16319 closedollehar Labelset with 215 items save only the first 111 

Activities

cdorin

cdorin

2020-04-02 18:11

manager   ~56894

That sounds strange - could you please submit a step-by-step process to reproduce it?

ymca

ymca

2020-04-02 19:00

reporter   ~56899

I'll try...
I don't know if you can, because most of the time I have problems that others don't have.
I always say to my friends I can be a bug finder for windows.

  1. I had 25+ tabs in the Brave browser.
  2. Was editing a survey that I had created.
  3. Clicked "edit" the question with the long country list.
  4. Went to "quick add", wrote something and clicked "replace" so it will delete the list that was already there.
  5. Clicked "quick add" again and pasted the country list and clicked "replace".
    I have tried many things to try to solve this problem (because I had a problem with sorting of countries by a-z) like clicking "add", deleting one answer by one, deleting question and creating it again from scratch .
    Nothing helped so now I only use the "Sort answers alphabetically" for the problematic question of the countries.

I have a couple of questions with lists.
Most of the question with the lists are short.
I have 2 questions with a very long answer list that is the country.
the first list is fine and the second does the problem, that is the strange thing.
The question with the short answers do not have this problem and I don't use the "Sort answers alphabetically".

I tried to see if my computer was overload so opened the task manager and saw ~70% memory usage when I have 8G ram.

I hope I helped you reproduce it.

ymca

ymca

2020-04-02 19:13

reporter   ~56900

Here is the survey attached

ymca

ymca

2020-04-03 01:38

reporter   ~56911

I'm sorry, I think I've mixed up this bug with another.
Just use my survey

  1. Add a new language to the survey
  2. Go to "G2Q00005", click the new language,
  3. Click "Answer options" to see it has same answers as the English default language.
  4. Change back to English, and go again to "Answer options".
  5. Click "quick add" (countries list should be there)
  6. Click "replace" (Same codes, I didn't change them)
  7. Change back to new language
  8. Go again to "Answer options".
  9. List of the new language is empty.
ymca

ymca

2020-04-29 02:43

reporter   ~57442

The empty depends on the order of the adding of the language.
If admin adds the language before all of the survey is ready, then the new question that were created after translation was added, will be empty.
Also now after I've activated the survey the translator finished translating in his language.
But now I cannot add the languages that he translated (or any other for that matter).
Is this a bug or a feature, not to be able to add languages after the survey is active?

ymca

ymca

2020-04-29 03:11

reporter   ~57443

"Also now after I've activated the survey..."
Sorry my bad. Found why. Re-added the language for the site and saw the language there.

DenisChenu

DenisChenu

2020-04-29 09:22

developer   ~57445

Can you give your current max_input_vars ?
https://manual.limesurvey.org/Troubleshooting#After_clicking_.27Next.27_on_a_page_which_contains_a_big_number_of_answers.2Fsubquestions.2C_not_all_responses_are_being_saved

250 country , X each have 3 or 4 input X each language …

ymca

ymca

2020-04-29 11:29

reporter   ~57457

max_input_vars 5000

DenisChenu

DenisChenu

2020-04-29 11:41

developer   ~57460

How many language ?

Can you try with 100000 to max_input_vars ?

Sadly, LimeSurvey use a lot of POST values … and more in 4.X than in 3.X

ymca

ymca

2020-04-29 13:32

reporter   ~57462

For now I have 5 languages but the "countries" list is not translated to them (only English).
"Can you try with 100000 to max_input_vars ?" Don't know if I can change that on the server or not.

"Sadly, LimeSurvey use a lot of POST values … and more in 4.X than in 3.X"
I don't know how this works but, not better to insert value for each language and not all together?

Issue History

Date Modified Username Field Change
2020-04-01 18:05 ymca New Issue
2020-04-02 18:11 cdorin Note Added: 56894
2020-04-02 18:11 cdorin Assigned To => cdorin
2020-04-02 18:11 cdorin Status new => feedback
2020-04-02 19:00 ymca Note Added: 56899
2020-04-02 19:00 ymca Status feedback => assigned
2020-04-02 19:13 ymca File Added: feedback for limesurvey_survey_818256.lss
2020-04-02 19:13 ymca Note Added: 56900
2020-04-03 01:38 ymca Note Added: 56911
2020-04-29 02:43 ymca Note Added: 57442
2020-04-29 03:11 ymca Note Added: 57443
2020-04-29 09:22 DenisChenu Note Added: 57445
2020-04-29 11:29 ymca Note Added: 57457
2020-04-29 11:29 ollehar Product Version => 4.1.13
2020-04-29 11:41 DenisChenu Note Added: 57460
2020-04-29 13:32 ymca Note Added: 57462
2020-05-22 17:46 DenisChenu Relationship added related to 16319