View Issue Details

IDProjectCategoryView StatusLast Update
16050Bug reportsSurvey editingpublic2020-04-27 20:24
Reporterymca Assigned Tocdorin  
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version4.1.12 
Summary16050: Question array saving problems
Description

I chose "Array by column type: H" I used the "quick add" (problematic) button.
I don't know if I must use the default "SQ01;" but I wanted to paste many question so I needed to delete it.
But when I pasted my questions, it didn't give SQxx to my questions but A0xx.
I don't know if this matters for the survey system to function correctly (I hope you can tell me the answer).
After I've inserted also the answer in the same way I went to save the question.
Clicked "save" and saw a blank green bubble without a text error.
I've looked to the left and saw I don't have any question saved.
I clicked the group link and then it showed me the question.
I've tried to preview the survey and it was stuck in the "welcome/info" page.
When clicking "next" it looped to the same page.
I tried to change the "Array by column type: H" to "type: F" and it didn't change the saving problem.
I deleted the question and made a clean "Array by column type: F" and I was able to save it.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.12+200324
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionsame
Server OS (if known)
Webserver software & version (if known)
PHP Versionsame

Activities

davidrgl

davidrgl

2020-04-21 21:49

reporter   ~57297

we are having an issue that i feel may be similar, so I thought i would add some information assuming it is.
We are simply trying to add anser options, or change the order, or anything, and it will not save. It throws a 500 error I am pasting below, complaining about unique answer option codes. However, they are unique. As it only lets one answer option exist, i found i can bulk add them if removing everything, but then any changes and the issues reoccurs.
We are using postgres as the database back end.

{"success":false,"message":"Question has been stored, but an error happened: \nAnswer option couldn't be saved. Error: Array\n(\n [code] => Array\n (\n [0] => Answer codes must be unique by question\n )\n\n)\n","error":{"code":500,"type":"LSJsonException","errorCode":0,"message":"Question has been stored, but an error happened: \nAnswer option couldn't be saved. Error: Array\n(\n [code] => Array\n (\n [0] => Answer codes must be unique by question\n )\n\n)\n","file":"\/var\/www\/html\/application\/controllers\/admin\/questionedit.php","line":297,"trace":"#0 [internal function]: questionedit->saveQuestionData()\n#1 \/var\/www\/html\/framework\/web\/actions\/CAction.php(109): ReflectionMethod->invokeArgs()\n#2 \/var\/www\/html\/application\/core\/Survey_Common_Action.php(86): CAction->runWithParamsInternal()\n#3 \/var\/www\/html\/framework\/web\/CController.php(308): Survey_Common_Action->runWithParams()\n#4 \/var\/www\/html\/framework\/web\/CController.php(286): CController->runAction()\n#5 \/var\/www\/html\/framework\/web\/CController.php(265): CController->runActionWithFilters()\n#6 \/var\/www\/html\/application\/controllers\/AdminController.php(180): CController->run()\n#7 \/var\/www\/html\/framework\/web\/CWebApplication.php(282): AdminController->run()\n#8 \/var\/www\/html\/framework\/web\/CWebApplication.php(141): CWebApplication->runController()\n#9 \/var\/www\/html\/framework\/base\/CApplication.php(185): CWebApplication->processRequest()\n#10 \/var\/www\/html\/index.php(182): CApplication->run()\n#11 {main}","traces":[{"function":"saveQuestionData","class":"questionedit","type":"->","file":"unknown","line":0},{"file":"\/var\/www\/html\/framework\/web\/actions\/CAction.php","line":109,"function":"invokeArgs","class":"ReflectionMethod","type":"->"},{"file":"\/var\/www\/html\/application\/core\/Survey_Common_Action.php","line":86,"function":"runWithParamsInternal","class":"CAction","type":"->"},{"file":"\/var\/www\/html\/framework\/web\/CController.php","line":308,"function":"runWithParams","class":"Survey_Common_Action","type":"->"},{"file":"\/var\/www\/html\/framework\/web\/CController.php","line":286,"function":"runAction","class":"CController","type":"->"},{"file":"\/var\/www\/html\/framework\/web\/CController.php","line":265,"function":"runActionWithFilters","class":"CController","type":"->"},{"file":"\/var\/www\/html\/application\/controllers\/AdminController.php","line":180,"function":"run","class":"CController","type":"->"},{"file":"\/var\/www\/html\/framework\/web\/CWebApplication.php","line":282,"function":"run","class":"AdminController","type":"->"},{"file":"\/var\/www\/html\/framework\/web\/CWebApplication.php","line":141,"function":"runController","class":"CWebApplication","type":"->"},{"file":"\/var\/www\/html\/framework\/base\/CApplication.php","line":185,"function":"processRequest","class":"CWebApplication","type":"->"},{"file":"\/var\/www\/html\/index.php","line":182,"function":"run","class":"CApplication","type":"->"}]},"redirectTo":"\/index.php\/admin\/questioneditor\/sa\/view\/surveyid\/546757\/gid\/8\/qid\/33"}

davidrgl

davidrgl

2020-04-27 20:24

reporter   ~57402

attaching the full debug for you

Issue History

Date Modified Username Field Change
2020-03-26 23:26 ymca New Issue
2020-03-30 21:55 cdorin Assigned To => cdorin
2020-03-30 21:55 cdorin Status new => assigned
2020-04-21 21:49 davidrgl Note Added: 57297
2020-04-22 11:08 ollehar Product Version => 4.1.12
2020-04-27 20:24 davidrgl Note Added: 57402
2020-04-27 20:24 davidrgl File Added: Screenshot_2020-04-27 LimeSurvey(1).png