View Issue Details

IDProjectCategoryView StatusLast Update
16046Bug reportsSurvey editingpublic2020-04-19 17:06
Reporterong Assigned To 
PriorityhighSeveritypartial_block 
Status closedResolutionopen 
Product Version4.1.11 
Summary16046: question type RANK (R) can not be edited again
Description

This is an issue in version 4.1.12.

I can not edit the question type rank (R) again once it has been saved.

Steps To Reproduce

Create ranking question (type R)
add items to rank
save
test in preview
edit question again
save -> Can not be saved "Question cannot be stored. Please check the answer options for duplicates or empty codes." ... they are all ok, actually no need ti change anything from a working question - the error still occurs.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.12+200324
I will donate to the project if issue is resolvedNo
Browservivaldi/chromium
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 / 8.0.18
Server OS (if known)Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
Webserver software & version (if known)apache
PHP Version7.something

Activities

ong

ong

2020-03-25 18:50

reporter  

x.png (77,857 bytes)   
x.png (77,857 bytes)   
cdorin

cdorin

2020-04-02 19:32

manager   ~56903

Can't reproduce the issue unfortunately. Could you please send a .lss file where this issue is reproducible?

cdorin

cdorin

2020-04-17 20:19

manager   ~57227

Last edited: 2020-04-17 20:20

View 2 revisions

While this is incredibly strange, this happens onnly and only when you preview the question and then, edit, and then save. Thank you for your report!

cdorin

cdorin

2020-04-17 20:30

manager   ~57228

Last edited: 2020-04-17 20:31

View 2 revisions

LE: issue caused by random order question attribute. If enabled, it does not allow the questions to be saved without a page refresh.

LE2: Actually, you cannot edit at all the question if Random order is enabled

ong

ong

2020-04-18 08:52

reporter   ~57231

Hi cdorin,
thank you for your feedback - and I am actually happy, that, if I understand you correct, this is reproducible.
The LE and LE2 are internal notes - and not some question to me? If they are a question and you require something from me, please write again.

cdorin

cdorin

2020-04-19 17:06

manager   ~57250

Hey @ong, thank you for reporting it. No need for other info (the "later edits" are for others who follow the topic). To see when it will be solved, please check: 16153 .

Issue History

Date Modified Username Field Change
2020-03-25 18:50 ong New Issue
2020-03-25 18:50 ong File Added: x.png
2020-03-30 21:54 cdorin Assigned To => cdorin
2020-03-30 21:54 cdorin Status new => assigned
2020-04-01 17:13 cdorin Description Updated View Revisions
2020-04-01 17:13 cdorin Steps to Reproduce Updated View Revisions
2020-04-02 19:32 cdorin Note Added: 56903
2020-04-17 20:19 cdorin Note Added: 57227
2020-04-17 20:20 cdorin Note Edited: 57227 View Revisions
2020-04-17 20:30 cdorin Note Added: 57228
2020-04-17 20:31 cdorin Note Edited: 57228 View Revisions
2020-04-17 20:32 cdorin Assigned To cdorin =>
2020-04-17 20:32 cdorin Priority none => high
2020-04-17 20:32 cdorin Status assigned => confirmed
2020-04-18 08:52 ong Note Added: 57231
2020-04-19 17:05 cdorin Status confirmed => closed
2020-04-19 17:06 cdorin Note Added: 57250