View Issue Details

IDProjectCategoryView StatusLast Update
16040Bug reportsSurvey editingpublic2020-12-23 17:18
Reporterupond Assigned Tocdorin  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.11 
Fixed in Version4.4.0-RC1 
Summary16040: impossible to update ranking type questions
Descriptionwe made a ranking type question (type R)
with some values in answer's option
the question may be saved and works well
but, if we want edit it it's impossible
we got the error : La question ne peut être enregistrée. Merci de vérifier que les options de réponse n'ont pas de doublons ou de codes vides (morte or less like : question can not be saved, please verify that the response 's options have not dublicatas or empty codes...)

beside this problem there is a secondary trouble with this question type :
when assesements are enabled, you can insert an assesement value in answer's option ; but this seem not work when the total is displayed at the end. Note that I am not very practical with assesements, so may be there are some mistakes on my expetings for this last point... by the way the assesements part of the manual is, on my point of view, a little bit rought and i think it would be nice to improve it...

Anyway, thnaks a lot for your job and have a nice day - and take care of you in those pandemic times !!!!
Steps To Reproduceedit a rank type question
add some answer's options
save
edit againt this question ans change anyting in it : question text for instance or options)
try to save
you should got the error message
(note that in my case the assesements are enabled)
Additional Informationwe can workaround this bug by erasing all answer's options ; save the question ; edit it and populate again the options...

at start we suspected some simple quote (') escaping problem, or any truble due to accents ; but it is the same with just ascii chars.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.11+200316
I will donate to the project if issue is resolvedNo
Browserfirefox & chrome
Database & DB-Versionsorry cant know it now... it is one of the latest mariadb relases...
Server OS (if known)cent os 7
Webserver software & version (if known)
PHP VersionPHP Version 7.2.28

Activities

upond

upond

2020-03-25 11:41

reporter  

DenisChenu

DenisChenu

2020-03-25 18:16

developer   ~56776

Please : a complete lss file, not a lss.

With only this question
upond

upond

2020-03-26 10:09

reporter   ~56782

Hi Denis,
here is the complete survey.

thanks a lot and have a nice day
cdorin

cdorin

2020-12-23 17:18

manager   ~61097

Ranking question type was buggy in the early releases. Everything looks fine in 4.4.0 RC1

Issue History

Date Modified Username Field Change
2020-03-25 11:41 upond New Issue
2020-03-25 11:41 upond File Added: limesurvey_question_161.lsq
2020-03-25 18:16 DenisChenu Note Added: 56776
2020-03-26 10:09 upond File Added: limesurvey_survey_415545.lss
2020-03-26 10:09 upond Note Added: 56782
2020-12-23 17:18 cdorin Assigned To => cdorin
2020-12-23 17:18 cdorin Status new => closed
2020-12-23 17:18 cdorin Resolution open => fixed
2020-12-23 17:18 cdorin Fixed in Version => 4.4.0-RC1
2020-12-23 17:18 cdorin Note Added: 61097