View Issue Details

IDProjectCategoryView StatusLast Update
15950Bug reportsFile managerpublic2020-05-18 16:27
Reporterdrrcraig Assigned To 
PrioritynoneSeveritypartial_block 
Status newResolutionopen 
Product Version4.1.8 
Summary15950: Unable to access file manager in V4 or insert images
Description

I have a fresh install (same thing happened with a fresh install of V4.1.7) of V4.1.8 on a Windows 2016 IIS server v10 - PHP 7.2.7, MySQL ver 8.0.13

When I go to Configuration>File Manager I get "An error has occured and the file list could not be loaded: Error: You don't have permission to this folder" (see screen shot)

I have read/write to the Application>config, Upload, & Temp folders

Likely related when I to add an image I get a pop-up [objecdt Object} (see screen shot).

I've replicated this in Safari, Chrome, Firefox, & Brave on PC and Mac

I have used lime survey since v1 and have 3.21.2 running on the same box - no issues.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.8.2000302
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 8.0.13
Server OS (if known)Windows 2016 iis10
Webserver software & version (if known)
PHP Version7.2.7

Relationships

child of 16291 assignedollehar Development  Revert file manager to LS3 

Activities

drrcraig

drrcraig

2020-03-05 00:56

reporter  

ollehar

ollehar

2020-05-11 11:29

administrator   ~57675

Please update to the latest version and try again. Thank you.

drrcraig

drrcraig

2020-05-11 17:14

reporter   ~57685

I am able to add images to the question and it saves. I am not able to work with the file manager/server - when I click on it I get nothing just the help message.

I am also not able to access the file manger under settings - I get a permissions error.

Thank you for working on this.

drrcraig

drrcraig

2020-05-11 17:29

reporter   ~57687

Spoke too quickly. I tried it with a new survey and back to the object issue

With the new survey, I can see some items in the file list but none are clickable.

ollehar

ollehar

2020-05-11 17:34

administrator   ~57688

We'll probably revert to LS3 file manager and ckeditor soon. Then these bugs will be solved.

drrcraig

drrcraig

2020-05-11 17:46

reporter   ~57690

That would be great. Please keep me updated.

We use Limesurvey as a part of our Undergraduate Psychology Research program (we collected almost 2000 responses just this past spring). I have not switched over to 4 because of these issues but really want to.

That might also be related to the bug I filed on setting up new users with passwords (I get a permissions error when I do that as well).

Thank you,

Ron

Issue History

Date Modified Username Field Change
2020-03-05 00:56 drrcraig New Issue
2020-03-05 00:56 drrcraig File Added: 89B22B63-0B12-47CF-AD3D-802CD3442830.png
2020-03-05 00:56 drrcraig File Added: 25FABF92-8865-4BAD-9532-07CA23E148C5.png
2020-05-11 10:47 ollehar Category Plugins => File manager
2020-05-11 11:29 ollehar Note Added: 57675
2020-05-11 11:29 ollehar Status new => feedback
2020-05-11 17:14 drrcraig Note Added: 57685
2020-05-11 17:14 drrcraig File Added: Screen Shot 2020-05-11 at 11.12.17 AM.png
2020-05-11 17:14 drrcraig Status feedback => new
2020-05-11 17:29 drrcraig Note Added: 57687
2020-05-11 17:29 drrcraig File Added: Screen Shot 2020-05-11 at 11.27.54 AM.png
2020-05-11 17:29 drrcraig File Added: Screen Shot 2020-05-11 at 11.27.03 AM.png
2020-05-11 17:34 ollehar Note Added: 57688
2020-05-11 17:46 drrcraig Note Added: 57690
2020-05-11 17:46 drrcraig File Added: Screen Shot 2020-05-11 at 10.52.43 AM.png
2020-05-18 16:27 ollehar Relationship added child of 16291