View Issue Details

IDProjectCategoryView StatusLast Update
15916Bug reportsOtherpublic2020-06-25 10:18
ReporterAntonimo Assigned Toollehar  
PriorityhighSeverityminor 
Status newResolutionreopened 
Product Version4.1.6 
Summary15916: Email templates corrupted after editing
Description

Making a change to the e-mail templates for a survey will result in the e-mails being sent out as source code.

Steps To Reproduce

Edit e-mail template
Save
Send e-mail invitation (source code visible in preview and in received e-mail)

Added by Olle:

  • Edit email templates with both HTML turned off and on
  • Send out invitations with both HTML turned off and on
  • Switching between HTML on/off, both sending emails and editing
  • Attachment
  • Multiple language
  • Reset email template
  • Insert image anywhere in the email template
Additional Information

Inspecting the database, in Table: lime_surveys_languagesettings, field: surveyls_email_invite I see the source code. If this code is replaced with plain text, the layout reverts.

This branch enables ckeditor4 (in "Send invitation" page etc).

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.1.6+200220
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5.7.29
Server OS (if known)CLOUDLINUX 7.7 vmware
Webserver software & version (if known)
PHP Version7.3.14

Activities

Antonimo

Antonimo

2020-02-25 15:15

reporter  

capture_2020-02-25_124339.png (41,198 bytes)   
capture_2020-02-25_124339.png (41,198 bytes)   
cdorin

cdorin

2020-03-18 19:50

manager   ~56652

The HTML editor is also missing. Thanks for reporting it.

ollehar

ollehar

2020-04-23 17:04

administrator   ~57344

Last edited: 2020-04-30 14:54

Any reason why we can't restore this to LS3 functionality?

ollehar

ollehar

2020-04-27 14:27

administrator   ~57387

Last edited: 2020-04-30 14:54

There's also missing permission checks, and a separate Ajax call at each template change click.

ollehar

ollehar

2020-04-27 14:49

administrator   ~57390

Last edited: 2020-04-30 14:54

Another regression is the ability to upload files. In LS4 you have to go to survey resource management, you can't do it from the email template view.

ollehar

ollehar

2020-04-27 14:52

administrator   ~57391

Last edited: 2020-04-30 14:54

View 2 revisions

A pro with LS4 is that it automatically validates the expression on load (if this is what you want - if not, you're doing an extra Ajax request needlessly).\

Edit: Hm, no, not correct. There's another call for validation.

ollehar

ollehar

2020-04-27 14:56

administrator   ~57392

Last edited: 2020-04-30 14:54

Validation seems to be shown without proper formatting.

Selection_263.png (73,908 bytes)   
Selection_263.png (73,908 bytes)   
ollehar

ollehar

2020-04-27 15:13

administrator   ~57394

Last edited: 2020-04-30 14:54

"Reset this template" button seems buggy too for multiple languages compared to LS3.

ollehar

ollehar

2020-04-29 16:24

administrator   ~57468

Last edited: 2020-04-30 14:54

Yet another issue. Seems impossible (?) to insert an image at any point in the letter, in LS4.

And: LS4 cannot handle non-html emails - the rich-text editor is still there, even if html emails is set to off.

ollehar

ollehar

2020-04-29 16:28

administrator   ~57469

Last edited: 2020-04-30 14:54

The HTML editor is also missing. Thanks for reporting it.

Revert to LS3 fixes this issue as well, since it enables ckeditor4 again.

ollehar

ollehar

2020-04-30 14:32

administrator   ~57496

Last edited: 2020-04-30 14:54

Multiple other issues.

ashvini

ashvini

2020-06-25 07:21

reporter   ~58433

Any solution in this...?

ollehar

ollehar

2020-06-25 10:18

administrator   ~58441

The solution right now is to make sure you have email templates enabled in survey settings.

Issue History

Date Modified Username Field Change
2020-02-25 15:15 Antonimo New Issue
2020-02-25 15:15 Antonimo File Added: capture_2020-02-25_124339.png
2020-03-18 19:50 cdorin Note Added: 56652
2020-03-18 19:50 cdorin Priority none => high
2020-03-18 19:50 cdorin Status new => confirmed
2020-03-18 19:50 cdorin Steps to Reproduce Updated View Revisions
2020-04-23 13:45 ollehar Assigned To => ollehar
2020-04-23 13:45 ollehar Status confirmed => assigned
2020-04-23 17:04 ollehar Note Added: 57344
2020-04-27 14:27 ollehar Note Added: 57387
2020-04-27 14:49 ollehar Note Added: 57390
2020-04-27 14:52 ollehar Note Added: 57391
2020-04-27 14:54 ollehar Note Edited: 57391 View Revisions
2020-04-27 14:56 ollehar Note Added: 57392
2020-04-27 14:56 ollehar File Added: Selection_263.png
2020-04-27 15:13 ollehar Note Added: 57394
2020-04-29 16:24 ollehar Note Added: 57468
2020-04-29 16:28 ollehar Note Added: 57469
2020-04-29 17:32 ollehar Steps to Reproduce Updated View Revisions
2020-04-29 17:32 ollehar Steps to Reproduce Updated View Revisions
2020-04-30 14:31 swendrich Status assigned => resolved
2020-04-30 14:32 ollehar Status resolved => new
2020-04-30 14:32 ollehar Resolution open => reopened
2020-04-30 14:32 ollehar Note Added: 57496
2020-04-30 14:54 swendrich Status new => resolved
2020-04-30 14:55 ollehar Status resolved => new
2020-05-04 16:09 ollehar Additional Information Updated View Revisions
2020-05-04 17:47 ollehar Steps to Reproduce Updated View Revisions
2020-06-25 07:21 ashvini Note Added: 58433
2020-06-25 10:18 ollehar Note Added: 58441