View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16701Bug reportsOtherpublic2020-12-22 17:04
Reporterrencosch Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.3.17 
Summary16701: <br /> tags are added to e-mail template upon save
DescriptionWhen you save an HTML e-mail template, unwanted
tags are inserted into the code, rendering it useless.
Steps To ReproduceNavigate to e-mail templates
Enable the sourcode editor
Paste in some HTML code
Save the template
Check that various
tags have been added throughout the code everytime you save it
Additional Informationhttps://forums.limesurvey.org/forum/can-i-do-this-with-limesurvey/122376-advanced-e-mail-templates-html-lay-out
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)4.3.17+200921
I will donate to the project if issue is resolvedYes
BrowserFirefox 81.0 (have tried others as well)
Database & DB-VersionMariaDB 10.1.46
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4

Relationships

related to 16355 closedJHoeck Revert Ckeditor 5 to 4 and add it to vue 
related to 15916 closedollehar Email templates corrupted after editing 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

rencosch

rencosch

2020-09-28 12:24

reporter  

DenisChenu

DenisChenu

2020-09-28 14:43

developer   ~59972

Arg ,

In source mode : just chagnge vertcial tab :
is added.
See screencast
Peek 28-09-2020 14-43.gif (328,171 bytes)
DenisChenu

DenisChenu

2020-09-28 14:48

developer   ~59973

And move from code to html : broken.

@gabrieljenik : inside revert ckeditor project ?
Peek 28-09-2020 14-47.gif (332,226 bytes)
cdorin

cdorin

2020-10-13 17:04

manager   ~60176

Postponed since we will use the old HTML Editor for email templates (please wait for LS4.4 release)
rencosch

rencosch

2020-11-06 16:38

reporter   ~60582

@cdorin is there an ETA on the LS4.4 release?
cdorin

cdorin

2020-11-06 16:39

manager   ~60583

hey @rencosch - more work needs to be put into the question editor.
We hope end of November/beginning of December to release it.
cdorin

cdorin

2020-12-22 17:04

manager   ~61046

4.4.0 RC1 is released: https://community.limesurvey.org/downloads/
Would be great if you have time to test it - from what I see, the described issue is solved in there :)

Issue History

Date Modified Username Field Change
2020-09-28 12:24 rencosch New Issue
2020-09-28 12:24 rencosch File Added: Screenshot_2020-09-28 IB P Vragenlijsten.png
2020-09-28 12:24 rencosch File Added: Screenshot_2020-09-28 IB P Vragenlijsten(1).png
2020-09-28 12:24 rencosch File Added: Screenshot_2020-09-28 IB P Vragenlijsten(2).png
2020-09-28 14:43 DenisChenu Note Added: 59972
2020-09-28 14:43 DenisChenu File Added: Peek 28-09-2020 14-43.gif
2020-09-28 14:48 DenisChenu Note Added: 59973
2020-09-28 14:48 DenisChenu File Added: Peek 28-09-2020 14-47.gif
2020-10-06 16:16 DenisChenu Relationship added related to 16355
2020-10-06 16:18 DenisChenu Relationship added related to 15916
2020-10-13 17:04 cdorin Assigned To => cdorin
2020-10-13 17:04 cdorin Status new => acknowledged
2020-10-13 17:04 cdorin Note Added: 60176
2020-11-06 16:38 rencosch Note Added: 60582
2020-11-06 16:39 cdorin Note Added: 60583
2020-12-22 17:04 cdorin Status acknowledged => closed
2020-12-22 17:04 cdorin Resolution open => fixed
2020-12-22 17:04 cdorin Note Added: 61046