View Issue Details

IDProjectCategoryView StatusLast Update
15895Bug reportsSurvey editingpublic2020-03-18 23:16
Reportersantics Assigned Toc_schmitz  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.5 
Fixed in Version4.1.9 
Summary15895: [IIS+SQL Server installation] List of questions don't load
Description

When I try to access a survey's question list, the screen freezes and doesn't finish loading.

Steps To Reproduce

1.- You go into a survey
2.- Click on Question List in the side panel
3.- Screen freezes

Additional Information

Thanks to testing with Internet Explorer I was able to solve this, since in this web browser the screen doesn't be frozen, it instead displays an error message --> […]Bad SQL Sintax[…]

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.5
I will donate to the project if issue is resolvedNo
BrowserInternet Explorer, Edge, Chrome and Firefox
Database & DB-VersionSQL SERVER 2012
Server OS (if known)Windows Server 2012 R2
Webserver software & version (if known)IIS
PHP Version7.2.11

Activities

santics

santics

2020-02-19 13:08

reporter   ~56095

To resolve this, you need to change in 'application\models\question.php' the word group by [group] when it is being used to form an SQL statement.

For example on line 966:
$criteria->with = array('group' => array('alias' => 'g'), 'questionL10ns'=>array('alias'=>'ql10n', 'condition'=>"language='".$this->survey->language."'"));

You should change it to:
$criteria->with = array('[group]' => array('alias' => 'g'), 'questionL10ns'=>array('alias'=>'ql10n', 'condition'=>"language='".$this->survey->language."'"));

There were more cases in the code but I don't remember them anymore, and I no longer have this installation on my server.

I'm sorry.

DenisChenu

DenisChenu

2020-02-19 15:13

developer   ~56096

To resolve this, you need to change in 'application\models\question.php' the word group by [group] when it is being used to form an SQL statement.

It must have a Yii gloval solution, because we don't have to use it like this.

My opinon : we must use relations

cdorin

cdorin

2020-03-18 19:46

manager   ~56651

@c_schmitz, can you please take a look at this one?

Related Changesets

LimeSurvey: master dece010b

2020-03-05 15:22:56

ollehar

Details Diff
Dev: Small MSSQL fix Affected Issues
15895
mod - application/controllers/admin/questionedit.php Diff File

Issue History

Date Modified Username Field Change
2020-02-19 13:00 santics New Issue
2020-02-19 13:08 santics Note Added: 56095
2020-02-19 15:13 DenisChenu Note Added: 56096
2020-03-18 19:46 cdorin Note Added: 56651
2020-03-18 23:14 c_schmitz Assigned To => c_schmitz
2020-03-18 23:14 c_schmitz Status new => closed
2020-03-18 23:14 c_schmitz Resolution open => fixed
2020-03-18 23:14 c_schmitz Fixed in Version => 4.1.9
2020-03-18 23:16 c_schmitz Changeset attached => LimeSurvey master dece010b