View Issue Details

IDProjectCategoryView StatusLast Update
15849Bug reports[All Projects] Conditionspublic2020-02-14 16:56
Reportercl9261 Assigned To 
PrioritynoneSeverityminor 
Status newResolutionopen 
Product Version4.1.1 
Target VersionFixed in Version 
Summary15849: The conditions didn't work properly
Description

Dear team,

I created a question which can be shown only if specific options of two previous questions are selected. For example, Q1 and Q2 are single choice questions, Q3 is text display. Q3 can be shown only if "Q1 == 2 or Q2 == 1". Also there is a condition on Q2 which is "Q1 == 1". But when I set the condition of Q3 to "Q1 == 2 or Q2 == 1" and chose Q1 as 2, the Q3 didn't show.

Steps To Reproduce

Attached you can find the testing survey. You can choose Q1 as 2, so the expectation is that Q2 is hidden and Q3 is shown. But the result is Q2 and Q3 are hidden.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.1
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMYSQL 5.5
Server OS (if known)
Webserver software & version (if known)
PHP Version7.1

Activities

cl9261

cl9261

2020-02-11 17:51

reporter  

limesurvey_survey_457919.lss (40,958 bytes)
DenisChenu

DenisChenu

2020-02-11 17:53

developer   ~55877

Did you try using Q2.NAOK ?

cl9261

cl9261

2020-02-11 18:54

reporter   ~55879

Not yet...

cl9261

cl9261

2020-02-14 16:56

reporter   ~56025

Hello, could you please confirm if this is a bug or my condition is wrong? Thank you in advance!

Issue History

Date Modified Username Field Change
2020-02-11 17:51 cl9261 New Issue
2020-02-11 17:51 cl9261 File Added: limesurvey_survey_457919.lss
2020-02-11 17:53 DenisChenu Note Added: 55877
2020-02-11 18:54 cl9261 Note Added: 55879
2020-02-14 16:56 cl9261 Note Added: 56025