View Issue Details

IDProjectCategoryView StatusLast Update
15800Bug reportsSurvey editingpublic2020-02-21 13:38
Reporterdakis Assigned To 
Status newResolutionopen 
Product Version4.1.0 
Summary15800: Unable to save survey text elements and question groups

When I try to save a survey's text elements I get this error message and nothing saves:

Texts could not be stored. Reloading page.

When I try to save a question group, I get a similar error message (and again nothing saves):

Questiongroup could not be stored. Reloading page.

Saving questions seems to be working fine. I tried this with existing/previous surveys and with new surveys, same result.

I am on the latest v4, I tried clearing the cache both from the global settings, and also by deleting the tmp/assets files from the file system. I tried enabling debug mode (both mode 1 and 2) and I get no additional errors displayed, nothing.

In the chrome console I get this error (I've hidden my url for security purposes):

lstextelements.js:129343 TEXTEDITOR OBJECT TO BE TRANSFERRED: {postObject: {…}}
VM10742:1 POST 406
(anonymous) @ VM10742:1
send @ jquery-3.4.1.min.js:2
ajax @ jquery-3.4.1.min.js:2
s.ajax @ jquery-migrate-3.1.0.min.js:2
(anonymous) @ lstextelements.js:129343
__runAjax @ lstextelements.js:129343
$_post @ lstextelements.js:129343
saveData @ lstextelements.js:129343
(anonymous) @ lstextelements.js:20328
p.dispatch @ lstextelements.js:20328
dispatch @ lstextelements.js:20328
submitCurrentState @ lstextelements.js:129343
(anonymous) @ lstextelements.js:129343
dispatch @ jquery-3.4.1.min.js:2
v.handle @ jquery-3.4.1.min.js:2
trigger @ jquery-3.4.1.min.js:2
(anonymous) @ jquery-3.4.1.min.js:2
each @ jquery-3.4.1.min.js:2
each @ jquery-3.4.1.min.js:2
trigger @ jquery-3.4.1.min.js:2
run @ VM10761 adminbasics.min.js:1
(anonymous) @ VM10761 adminbasics.min.js:1
(anonymous) @ VM10761 adminbasics.min.js:1
baseForOwn @ VM10761 adminbasics.min.js:1
(anonymous) @ VM10761 adminbasics.min.js:1
forEach @ VM10761 adminbasics.min.js:1
(anonymous) @ VM10761 adminbasics.min.js:1
invokeWithErrorHandling @ VM10761 adminbasics.min.js:1
e.$emit @ VM10761 adminbasics.min.js:1
value @ VM10761 adminbasics.min.js:1
clicked @ VM10768 admintoppanel.js:31
oe @ VM10768 admintoppanel.js:31
r @ VM10768 admintoppanel.js:31
Ri.i._wrapper @ VM10768 admintoppanel.js:31
Show 4 more frames
VM10761 adminbasics.min.js:1 AdminCore StopLoadingIconAnimation

Steps To Reproduce

Edit a survey's text elements > click save.

Or edit a survey's question group > click save.

Tried old/existing surveys, new created surveys, and imported demo surveys. All present same problem.

Tried different browsers, same issue.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.0+200128
I will donate to the project if issue is resolvedYes
BrowserChrome, Firefox
Database & DB-VersionMysql - Server version: 5.6.41-84.1 - Percona Server (GPL)
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.7




2020-01-30 11:16

developer   ~55571

imported demo surveys. All present same problem.

When imported : did the imported text are here ?
It's to understand if it can be a SQL issue, or if it' GUI issue.



2020-01-30 11:21

reporter   ~55572

Yes the initial text is all there.



2020-01-30 11:23

developer   ~55573

OK, thanks …

Then seems to be a GUI error …



2020-01-31 15:31

administrator   ~55595

Cannot reproduce. Is this on a fresh install, or upgraded system?



2020-01-31 22:56

reporter   ~55610

Upgraded system. I can try to install fresh on a different directory and see if it does the same thing?



2020-02-04 04:26

reporter   ~55687

Ok so I did a fresh install in a new directory on the same server, and the new install does not have this problem. I went back checking settings etc, but couldn't find anything that was different - only the admin theme which I changed but that didn't make a difference.

So I guess I can attribute this to an issue with my specific install, something's happened to it. The important thing is that the software seems to be working properly in a new install.

Let me know if I can provide any more information or you want to close this issue :)



2020-02-04 10:12

administrator   ~55690

Could be cache issue. By which I mean, the Yii runtime cache. Can you still reproduce the problem on your broken installation? What if you empty the Yii runtime cache?



2020-02-04 23:26

reporter   ~55723

What's a "yii runtime cache" and how do I empty it?



2020-02-05 14:34

administrator   ~55761

What's a "yii runtime cache" and how do I empty it?

Yii has a number of caches. They are all in your configured tmp/ folder. Please remove all files in:


Thank you.



2020-02-05 22:50

reporter   ~55769

Thanks yes I have deleted these twice, and nothing has changed.



2020-02-21 13:38

administrator   ~56136

Why would this be considered "low" priority?

Issue History

Date Modified Username Field Change
2020-01-30 08:05 dakis New Issue
2020-01-30 10:48 cdorin Assigned To => cdorin
2020-01-30 10:48 cdorin Status new => assigned
2020-01-30 11:16 DenisChenu Note Added: 55571
2020-01-30 11:21 dakis Note Added: 55572
2020-01-30 11:23 DenisChenu Note Added: 55573
2020-01-31 13:47 ollehar Priority none => urgent
2020-01-31 15:31 ollehar Note Added: 55595
2020-01-31 15:31 ollehar Status assigned => feedback
2020-01-31 22:56 dakis Note Added: 55610
2020-01-31 22:56 dakis Status feedback => assigned
2020-02-04 04:26 dakis Note Added: 55687
2020-02-04 10:12 ollehar Note Added: 55690
2020-02-04 23:26 dakis Note Added: 55723
2020-02-05 10:59 cdorin Assigned To cdorin =>
2020-02-05 10:59 cdorin Assigned To => cdorin
2020-02-05 10:59 cdorin Status assigned => new
2020-02-05 14:34 ollehar Note Added: 55761
2020-02-05 14:35 ollehar Status new => feedback
2020-02-05 22:50 dakis Note Added: 55769
2020-02-05 22:50 dakis Status feedback => assigned
2020-02-21 00:23 cdorin Assigned To cdorin =>
2020-02-21 00:24 cdorin Status assigned => new
2020-02-21 00:25 cdorin Priority urgent => low
2020-02-21 13:38 ollehar Note Added: 56136