View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
15768Bug reportsUser / Groups / Rolespublic2021-07-12 11:53
ReporterMazi Assigned Togabrieljenik  
PrioritynormalSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.0.0-RC12 
Summary15768: After adding new admin users the user it not redirected to setting user rights afterwards
DescriptionWhen adding a new user at LS3, the next step after the user was created was presenting a button to define the user rights which is the logical next step.
At LS4 you just add a user and get a "sucess" notification. It is not mentioned at all that you also have to define the user rights as well. So either add the same screen as at LS3 or, my suggestion, directly load the screen for setting the user rights including a short notification onn top that the user was added (and maybe an email was sent). That will improve the GUI since it connects the logical steps of creating a user and assigning him/her the proper user rights as well.
Steps To ReproduceAdd a new admin user at LS4. Compare with the LS3 work flow.
Additional Information@cdorin, this is a regression that should be fixed soon. Otherwise you can expect many support requests.
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)Version 4.01
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL
Server OS (if known)Ubuntu 18
Webserver software & version (if known)Apache 2
PHP Version7.2.26

Activities

Mazi

Mazi

2020-02-07 14:36

partner   ~55808

@cdorin, when having set user rights, it looks like there is some kind of debug output, see attached screenshot. This should either be removed ti somply show a green "...success..." message or list the assigned user rights in a nicer way.
image.png (22,410 bytes)   
image.png (22,410 bytes)   
DenisChenu

DenisChenu

2020-02-07 18:25

developer   ~55809

Last edited: 2020-12-28 18:25

Global message OR

> Super admin rights set, DB authentification right set.
gabrieljenik

gabrieljenik

2021-03-26 22:22

manager   ~63659

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1824

Have to say handling CRUD on modals is getting harder to manage.
As for future considerations.
DenisChenu

DenisChenu

2021-03-27 11:27

developer   ~63661

> Have to say handling CRUD on modals is getting harder to manage.

+ 15369 !

Modal must be used ONLY for 2 or 3 settings !
gabrieljenik

gabrieljenik

2021-03-29 14:25

manager   ~63703

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31425
c_schmitz

c_schmitz

2021-07-12 11:53

administrator   ~65331

Release done.

Related Changesets

LimeSurvey: master 0959a61e

2021-03-29 14:25:49

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 15768: After adding new admin users the user it not redirected to setting user rights afterwards (#1824)

Dev Opening modal after creating user
Affected Issues
15768
mod - application/controllers/UserManagementController.php Diff File
mod - assets/packages/usermanagement/js/usermanagement.js Diff File

Issue History

Date Modified Username Field Change
2020-01-24 12:09 Mazi New Issue
2020-02-05 08:55 cdorin Assigned To => cdorin
2020-02-05 08:55 cdorin Status new => assigned
2020-02-07 14:36 Mazi File Added: image.png
2020-02-07 14:36 Mazi Note Added: 55808
2020-02-07 18:25 DenisChenu Note Added: 55809
2020-02-22 20:38 cdorin Priority none => low
2020-02-22 20:38 cdorin Status assigned => confirmed
2020-12-28 18:25 cdorin Assigned To cdorin =>
2020-12-28 18:25 cdorin Priority low => normal
2021-03-26 22:22 gabrieljenik Note Added: 63659
2021-03-27 11:27 DenisChenu Note Added: 63661
2021-03-29 14:25 gabrieljenik Changeset attached => LimeSurvey master 0959a61e
2021-03-29 14:25 gabrieljenik Note Added: 63703
2021-03-29 14:25 gabrieljenik Assigned To => gabrieljenik
2021-03-29 14:25 gabrieljenik Resolution open => fixed
2021-03-29 14:26 c_schmitz Status confirmed => resolved
2021-07-12 11:53 c_schmitz Note Added: 65331
2021-07-12 11:53 c_schmitz Bug heat 6 => 8
2021-07-12 11:53 c_schmitz Status resolved => closed