View Issue Details

IDProjectCategoryView StatusLast Update
15666Bug reportsUser / Groups / Rolespublic2021-02-19 08:52
Reporterjelo Assigned Togabrieljenik  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.4.0-RC1 
Summary15666: Change password of an account with an email used more than once
Description

If you add a new user with a E-Mailadress already in use (SuperAdministrator in my case) and change the password of that new account, you'll get an error that the password cannot be changed. After changing the emailadress you can change the password.

The sideeffect is that LimeSurvey is now warning that the first account (which is the using the emailadress all the time) has never changed the default password (which isn't that case).

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.21.2+191216
I will donate to the project if issue is resolvedNo
Sync to Zoho ProjectYes
Browser
Database & DB-VersionMySQL 5.7
Server OS (if known)
Webserver software & version (if known)
PHP Version7.1.X

Activities

cdorin

cdorin

2020-12-29 17:57

manager   ~61286

To be fixed in LS4 dev branch

gabrieljenik

gabrieljenik

2021-02-18 21:48

developer   ~62370

Thsi is kind of old. Couldn't reproduce it now.
Can you please try again?

Thanks!

jelo

jelo

2021-02-18 22:13

partner   ~62373

I reported that issue for Version 3.21.2+191216 in 2019.
In Feb 2021 I receive an request to try it again.
Which version? LS3 or LS4?

The bug handling process is a bit broken, isn't it?
Till today LS4 is not ready for production.
So the learning seems to be: Don't change the target version of issues from LS3 to LS4.

Please close this ticket. Thanks for your time.

DenisChenu

DenisChenu

2021-02-19 08:52

developer   ~62384

So the learning seems to be: Don't change the target version of issues from LS3 to LS4.

+1

Issue History

Date Modified Username Field Change
2019-12-17 17:37 jelo New Issue
2020-01-10 15:41 cdorin Assigned To => cdorin
2020-01-10 15:41 cdorin Status new => assigned
2020-12-29 17:57 cdorin Assigned To cdorin =>
2020-12-29 17:57 cdorin Priority none => normal
2020-12-29 17:57 cdorin Status assigned => confirmed
2020-12-29 17:57 cdorin Product Version 3.21.2 => 4.4.0-RC1
2020-12-29 17:57 cdorin Sync to Zoho Project => Yes
2020-12-29 17:57 cdorin Note Added: 61286
2021-02-18 21:48 gabrieljenik Note Added: 62370
2021-02-18 22:13 jelo Note Added: 62373
2021-02-18 22:40 gabrieljenik Assigned To => gabrieljenik
2021-02-18 22:40 gabrieljenik Status confirmed => closed
2021-02-18 22:40 gabrieljenik Resolution open => fixed
2021-02-19 08:52 DenisChenu Note Added: 62384