View Issue Details

IDProjectCategoryView StatusLast Update
15639Bug reports_ Unknownpublic2020-12-29 15:56
Reportertassoman Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionno change required 
Product Version3.25.6 
Target Version3.x 
Summary15639: Symbol is Undefined on IE11
DescriptionI would ask you if you're using Babel to compile javascripts inside limesurvey.
I'm getting "Symbol is undefined" error in backend and during survey filling either.
I know IE11 is no more supported, I've read the admin error notification during login.
I found this link about Babel and React, maybe could be related?
https://stackoverflow.com/questions/33828840/symbol-is-undefined-in-ie-after-using-babel
Steps To Reproduce1. Install a plain 3.18 / 3.19 limesurvey
2. open it with IE11
3. browse a survey
4. open dev-tools inside IE11
5. read the console
6. find "Symbol is undefined" in jquery-3.4.1.min.js
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.18.0+190923
I will donate to the project if issue is resolvedNo
BrowserIE11
Database & DB-VersionMySql
Server OS (if known)
Webserver software & version (if known)
PHP VersionPHP 7.3

Activities

cdorin

cdorin

2019-12-04 11:24

manager   ~54944

@markusfluer
cdorin

cdorin

2019-12-04 15:37

manager   ~54949

Could you please update your instnace? Could you also send us a screenshot(s) with the error?
tassoman

tassoman

2019-12-04 16:11

reporter   ~54951

Ok. I will update this ticket when we're going to be ready to update to current stable version.
tassoman

tassoman

2020-01-16 12:57

reporter   ~55315

Nevermind. I had some problems in a personal template.
It's just working on latest master pulled from git.
cdorin

cdorin

2020-01-16 13:26

manager   ~55318

@tassoman, thx for update! Do you use LS 4.0?
tassoman

tassoman

2020-01-16 14:46

reporter   ~55319

HUH Sorry I was wrong, I've checked out in the past the version 3.21.3 but I forgot pulling the master branch.
Now I've pulled the master branch and I have an error:

500: Internal Server Error
The table "{{surveys_groupsettings}}" for active record class "SurveysGroupsettings" cannot be found in the database.

Is there any upgrade script?
cdorin

cdorin

2020-12-28 18:40

manager   ~61255

hey @tassoman - sorry for the very late reply.
In case you use LS4 - try 4.4.0 RC1 and see if the issue was fixed in there
tassoman

tassoman

2020-12-29 11:51

reporter   ~61269

Hello @cdorin I'm not ready testing LS4 yet. I'm going to do it lately during next year 2021.
In the mean time IE11 got deprecated in favor of Edge with a massive forced installation by Microsoft.
This bug would affect "just" clients using Windows 7 who is deprecated too.
So means we're not going supporting it in our LS installation, neither in LS development, I bet.
In my opinion is a low priority task. Thanks for support.
cdorin

cdorin

2020-12-29 15:56

manager   ~61270

Thanks @tassoman for your feedback.
I will then close the tickets since we (and admins hopefully) recommend their users to upgrade and use Edge.

Issue History

Date Modified Username Field Change
2019-12-04 09:16 tassoman New Issue
2019-12-04 11:24 cdorin Note Added: 54944
2019-12-04 15:37 cdorin Note Added: 54949
2019-12-04 15:38 cdorin Assigned To => cdorin
2019-12-04 15:38 cdorin Status new => feedback
2019-12-04 16:11 tassoman Note Added: 54951
2019-12-04 16:11 tassoman Status feedback => assigned
2020-01-16 12:57 tassoman Note Added: 55315
2020-01-16 13:26 cdorin Note Added: 55318
2020-01-16 14:46 tassoman Note Added: 55319
2020-12-28 18:40 cdorin Note Added: 61255
2020-12-28 18:40 cdorin Assigned To cdorin =>
2020-12-28 18:40 cdorin Status assigned => feedback
2020-12-29 11:51 tassoman Note Added: 61269
2020-12-29 11:51 tassoman Status feedback => new
2020-12-29 14:31 ollehar Product Version => 3.25.6
2020-12-29 14:31 ollehar Target Version => 3.x
2020-12-29 15:56 cdorin Note Added: 61270
2020-12-29 15:56 cdorin Assigned To => cdorin
2020-12-29 15:56 cdorin Status new => closed
2020-12-29 15:56 cdorin Resolution open => no change required