View Issue Details

IDProjectCategoryView StatusLast Update
15430Bug reports[All Projects] Statisticspublic2019-11-11 16:01
ReporterMazi Assigned Top_teichmann  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.19.2 
Target VersionFixed in Version 
Summary15430: Bars at statistics are often hardly visible / Wrong bar colors
Description
  1. When showing charts at the statistics feature some of the bars are hardly visible. Only when hovering a bar with the mouse, the bar is shown in a darker way, see attached screen shot.

  2. The bar chart uses the color of the first bar for all bars. According to the legend, there should be multiple, different colors, see screenshot.

Steps To Reproduce

Call the statistics featrue with a survey with multiple questions. Enable "View summary of all fields" and "Show graphs". Then check the graphs. Some bars are visible, other use very light colors and can sometimes hardly be seen.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.19.2
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.2

Relationships

child of 15378 closedp_teichmann Color randomization in expert statistics (issue) 

Activities

Mazi

Mazi

2019-10-21 09:11

partner  

image.png (66,053 bytes)
image.png (66,053 bytes)
Mazi

Mazi

2019-10-21 09:12

partner   ~54125

@cdorin, this is an issue that should be simple to fix. Since a customer uses these statistics a lot and sometimes bars can't be seen, can you assign this with proper priority?
Thanks!

Mazi

Mazi

2019-10-21 09:16

partner   ~54126

I just tested with an older version (3.17.7) and there both issues did NOT show up. Even the tooltip for a bar looks better, see screenshot.



stats_ls3_17.png (66,989 bytes)
stats_ls3_17.png (66,989 bytes)
Mazi

Mazi

2019-10-30 09:07

partner   ~54260

@cdorin, this is a fix required urgently by one of our customers. Is there a chance to include the fix to the next release?

If you lack resources, can you point me to the file that needs to be adjusted? As outlined above, at a previous version this looked fine so that seems to have been changed recently. Maybe you find the related commit and can hand us a link so we can try providding a fix?

p_teichmann

p_teichmann

2019-11-08 16:11

administrator   ~54487

Last edited: 2019-11-08 16:15

View 2 revisions

Fix committed to master branch: https://github.com/LimeSurvey/LimeSurvey/commit/a6055c22038f68c71d4a14f83a5782c91bd7293b

lime_release_bot

lime_release_bot

2019-11-11 14:55

administrator   ~54519

Fixed in Release 3.20.0+191112

Mazi

Mazi

2019-11-11 16:01

partner   ~54523

Working fine now, thanks for fixing, p_teichmann!

Related Changesets

LimeSurvey: master a6055c22

2019-11-08 16:10:21

p_teichmann

Details Diff
Fixed issue 15430: Bars at statistics are often hardly visible / Wrong bar colors Affected Issues
15430
mod - application/helpers/admin/statistics_helper.php Diff File
mod - application/views/admin/export/generatestats/_statisticsoutput_graphs.php Diff File
mod - assets/scripts/admin/statistics.js Diff File

Issue History

Date Modified Username Field Change
2019-10-21 09:11 Mazi New Issue
2019-10-21 09:11 Mazi File Added: image.png
2019-10-21 09:12 Mazi Note Added: 54125
2019-10-21 09:16 Mazi File Added: stats_ls3_17.png
2019-10-21 09:16 Mazi Note Added: 54126
2019-10-30 09:07 Mazi Note Added: 54260
2019-10-30 19:44 Mazi Relationship added child of 15378
2019-11-08 16:11 p_teichmann Changeset attached => LimeSurvey master a6055c22
2019-11-08 16:11 p_teichmann Note Added: 54487
2019-11-08 16:11 p_teichmann Assigned To => p_teichmann
2019-11-08 16:11 p_teichmann Resolution open => fixed
2019-11-08 16:15 p_teichmann Note Edited: 54487 View Revisions
2019-11-11 14:55 lime_release_bot Note Added: 54519
2019-11-11 14:55 lime_release_bot Status new => closed
2019-11-11 16:01 Mazi Note Added: 54523