View Issue Details

IDProjectCategoryView StatusLast Update
15369Bug reports[All Projects] Survey takingpublic2019-10-23 11:57
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version3.18.0 
Target VersionFixed in Version 
Summary15369: Ranking with filter didn't save all value
Description

If you filter partially a ranking question : all value are not saved

Steps To Reproduce

Import included survey
Check no value in 1st question
Activate and rank all item
The 2 last item are not saved

Additional Information

After this fix
https://github.com/LimeSurvey/LimeSurvey/commit/c4309bd9052ce864b746d4da7b9acf503d750392

In fact : allow to rank exactly number of question checked in 1st one

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.18.0 git c4309bd
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 15368 closedDenisChenu Filtered ranking didn't appear if in same page than the filter 
related to 15385 assignedollehar Still an issue with Ranking : rank condition in logic file is invalid … 
child of 15348 closedollehar Ranking question does not save answers when array filter and max columns are used 

Activities

DenisChenu

DenisChenu

2019-10-04 17:35

developer  

limesurvey_survey_RankingFilterPartial.lss (27,851 bytes)
DenisChenu

DenisChenu

2019-10-04 17:37

developer   ~53898

Last edited: 2019-10-04 17:51

View 2 revisions

@ollehar : see the issue with partial filter …

See the comment here : https://github.com/LimeSurvey/LimeSurvey/pull/1325/commits/edbd436eadc984a542e717602eb44b4b9850b0c9#diff-796aba4d06254b9caea9d461e4ea80c9R6269

DenisChenu

DenisChenu

2019-10-04 17:50

developer   ~53899

OK remove the TODO
https://github.com/LimeSurvey/LimeSurvey/pull/1325

DenisChenu

DenisChenu

2019-10-07 16:09

developer   ~53926

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29181

ollehar

ollehar

2019-10-07 16:35

administrator   ~53928

Should I create a test for this bug?

ollehar

ollehar

2019-10-07 16:54

administrator   ~53929

Is it fixed? Can we resolve it?

DenisChenu

DenisChenu

2019-10-07 18:26

developer   ~53931

Should I create a test for this bug?

Maybe :)

Is it fixed? Can we resolve it?
Yes :)

It's OK for the detail in comment ?

ollehar

ollehar

2019-10-08 10:12

administrator   ~53934

Your nice and detailed comments didn't survive the merge to develop branch - maybe because you added something in dev after doing the master changes? Is it safe to copy-paste the nice code from master to dev?

DenisChenu

DenisChenu

2019-10-08 10:30

developer   ~53935

No, i need to update it … (\Answer was updated)
If it's the only merge issue : i make it in some minutes.

lime_release_bot

lime_release_bot

2019-10-08 10:32

administrator   ~53936

Fixed in Release 3.19.0+191008

DenisChenu

DenisChenu

2019-10-08 10:44

developer   ~53943

@ollehar : develop seems OK after this : https://github.com/LimeSurvey/LimeSurvey/commit/3d9af5bfa537febd6bce059c6718012ac4417845
(tested)

DenisChenu

DenisChenu

2019-10-08 10:45

developer   ~53944

Manually checked (didn't check test …)

ollehar

ollehar

2019-10-08 10:48

administrator   ~53945

Tests are broken, I'm fixing it now.

DenisChenu

DenisChenu

2019-10-08 10:51

developer   ~53946

Last edited: 2019-10-08 10:51

View 2 revisions

The (javascript) don't find element by id can be clearly due to Broken page : \Answer::model()->count('qid = :qid and language = :language',array(':qid'=>$qid,':language'=>$language)); broke page with a 500 error in develop.

tpartner

tpartner

2019-10-22 19:09

developer   ~54149

Last edited: 2019-10-22 19:10

View 2 revisions

This commit completely breaks the ranking question for me in 3.19.2 with debug=1 - See attached screenshot and survey.



bug_10.png (48,589 bytes)
bug_10.png (48,589 bytes)
limesurvey_survey_881714.lss (15,497 bytes)
DenisChenu

DenisChenu

2019-10-23 07:42

developer   ~54150

Didn't test with no filter …

I fix it .

DenisChenu

DenisChenu

2019-10-23 09:18

developer   ~54154

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29208

ollehar

ollehar

2019-10-23 09:56

administrator   ~54161

Thanks for the fix, Denis. Guess we'll release today. :)

ollehar

ollehar

2019-10-23 09:56

administrator   ~54162

@tpartner Can you please attach an lss file so I can add a test for it?

DenisChenu

DenisChenu

2019-10-23 10:46

developer   ~54171

@ollehar : we don't do test with debug > 0, right ?

DenisChenu

DenisChenu

2019-10-23 10:47

developer   ~54172

Because a PHP warning are shown only with debug > 0

ollehar

ollehar

2019-10-23 10:53

administrator   ~54174

No, Travis runs with debug = 0. Because this is what people run LS with.

ollehar

ollehar

2019-10-23 10:54

administrator   ~54175

We've had issues where it was broken with debug = 0 but worked when debug = 2. That's why we always run tests with debug = 0.

tpartner

tpartner

2019-10-23 11:45

developer   ~54180

@ollehar : I did attach a sample survey to my report yesterday and my issue occurs with debug=1.

DenisChenu

DenisChenu

2019-10-23 11:47

developer   ~54182

Last edited: 2019-10-23 11:47

View 2 revisions

Yes, and the last issue happen ONLY with debug > 0

The original issue happen with debug == 0

Original issue fix : https://github.com/LimeSurvey/LimeSurvey/commit/f441cd5c53bd9c19ae8d027b2ae0b8905b44db50
New issue fix (with debug > 0 only) https://github.com/LimeSurvey/LimeSurvey/commit/95df8c3868cae9560cebea33d66aee67137d933c

tpartner

tpartner

2019-10-23 11:50

developer   ~54183

Thanks Denis, I'll test this morning.

ollehar

ollehar

2019-10-23 11:57

administrator   ~54184

@tpartner Ah, sorry, missed that. Great!

Related Changesets

LimeSurvey: master f441cd5c

2019-10-07 16:09:24

DenisChenu


Committer: ollehar Details Diff
[READY] Fix 15369 and details and separations in ranking filter (#1325)

Dev: details and separations in ranking filter
Dev: typo
Fixed issue 15369: Ranking with filter didn't save all value
Dev: get count of answers by model …
Dev: remove TODO FIXIT because it's done …
Dev: more details
Affected Issues
15369
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: master 95df8c38

2019-10-23 09:18:47

DenisChenu

Details Diff
Dev: Fixed issue 15369 child : throw error with debug > 0 in ranking
Dev: check if there are filter before use array_filter
Affected Issues
15369
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2019-10-04 17:35 DenisChenu New Issue
2019-10-04 17:35 DenisChenu File Added: limesurvey_survey_RankingFilterPartial.lss
2019-10-04 17:36 DenisChenu Relationship added child of 15348
2019-10-04 17:37 DenisChenu Note Added: 53898
2019-10-04 17:50 DenisChenu Note Added: 53899
2019-10-04 17:51 DenisChenu Note Edited: 53898 View Revisions
2019-10-05 09:15 DenisChenu Assigned To => DenisChenu
2019-10-05 09:15 DenisChenu Status new => assigned
2019-10-06 10:56 DenisChenu Relationship added related to 15368
2019-10-07 16:09 ollehar Changeset attached => LimeSurvey master f441cd5c
2019-10-07 16:09 DenisChenu Note Added: 53926
2019-10-07 16:09 DenisChenu Resolution open => fixed
2019-10-07 16:35 ollehar Note Added: 53928
2019-10-07 16:54 ollehar Note Added: 53929
2019-10-07 18:26 DenisChenu Status assigned => resolved
2019-10-07 18:26 DenisChenu Fixed in Version => 3.18.x
2019-10-07 18:26 DenisChenu Note Added: 53931
2019-10-08 10:12 ollehar Note Added: 53934
2019-10-08 10:30 DenisChenu Note Added: 53935
2019-10-08 10:32 lime_release_bot Note Added: 53936
2019-10-08 10:32 lime_release_bot Status resolved => closed
2019-10-08 10:44 DenisChenu Note Added: 53943
2019-10-08 10:45 DenisChenu Note Added: 53944
2019-10-08 10:48 ollehar Note Added: 53945
2019-10-08 10:51 DenisChenu Note Added: 53946
2019-10-08 10:51 DenisChenu Note Edited: 53946 View Revisions
2019-10-08 17:04 DenisChenu Relationship added related to 15385
2019-10-22 19:09 tpartner File Added: bug_10.png
2019-10-22 19:09 tpartner File Added: limesurvey_survey_881714.lss
2019-10-22 19:09 tpartner Note Added: 54149
2019-10-22 19:10 tpartner Note Edited: 54149 View Revisions
2019-10-23 07:42 DenisChenu Status closed => assigned
2019-10-23 07:42 DenisChenu Note Added: 54150
2019-10-23 09:18 DenisChenu Changeset attached => LimeSurvey master 95df8c38
2019-10-23 09:18 DenisChenu Note Added: 54154
2019-10-23 09:19 DenisChenu Status assigned => resolved
2019-10-23 09:19 DenisChenu Fixed in Version 3.18.x => 3.19.4
2019-10-23 09:56 ollehar Note Added: 54161
2019-10-23 09:56 ollehar Note Added: 54162
2019-10-23 10:46 DenisChenu Note Added: 54171
2019-10-23 10:47 DenisChenu Note Added: 54172
2019-10-23 10:53 ollehar Note Added: 54174
2019-10-23 10:54 ollehar Note Added: 54175
2019-10-23 11:45 tpartner Note Added: 54180
2019-10-23 11:47 DenisChenu Note Added: 54182
2019-10-23 11:47 DenisChenu Note Edited: 54182 View Revisions
2019-10-23 11:50 tpartner Note Added: 54183
2019-10-23 11:57 ollehar Note Added: 54184