View Issue Details

IDProjectCategoryView StatusLast Update
15368Bug reports[All Projects] Survey takingpublic2019-10-17 12:01
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.18.x 
Target VersionFixed in Version3.18.x 
Summary15368: Filtered ranking didn't appear if in same page than the filter
Description

With a filtered rankingquestion, if all question are hidden by filter when page is shown : it doesn't appear when page

Steps To Reproduce

Import included survey, test
See the multiple appear but nit the ranking

Additional Information

Related to hideQuestionWithRelevanceSubQuestion

This event happen : https://github.com/LimeSurvey/LimeSurvey/blob/33bb396294cd25a981234d71c6282fddd01dc8a7/assets/packages/template-core/template-core.js#L119

But this one not : https://github.com/LimeSurvey/LimeSurvey/blob/33bb396294cd25a981234d71c6282fddd01dc8a7/assets/packages/template-core/template-core.js#L110

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.18.0
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 15369 closedDenisChenu Bug reports Ranking with filter didn't save all value 
related to 15348 closedollehar Bug reports Ranking question does not save answers when array filter and max columns are used 
related to 15398 assignedDenisChenu Development  Must create a test for 15368: Filtered ranking didn't appear if in same page than the filter 

Activities

DenisChenu

DenisChenu

2019-10-04 16:59

developer  

limesurvey_survey_RankingFilterSamePage.lss (27,026 bytes)
DenisChenu

DenisChenu

2019-10-06 10:56

developer   ~53905

Sorry , bad number :)

DenisChenu

DenisChenu

2019-10-10 18:14

developer   ~53993

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29191

lime_release_bot

lime_release_bot

2019-10-14 13:57

developer   ~54030

Fixed in Release 4.0.0-RC5+191014

DenisChenu

DenisChenu

2019-10-14 15:46

developer   ~54038

For master, not only develop.

Must review the bot :)

lime_release_bot

lime_release_bot

2019-10-17 12:01

developer   ~54084

Fixed in Release 3.19.2+191017

Related Changesets

LimeSurvey: master af8336f3

2019-10-10 18:14:05

DenisChenu

Details Diff
Fixed issue 15368: Filtered ranking didn't appear if in same page than the filter
Dev: don't off default event
Dev: default event happen when view, but not after : off is done after default …
Dev: can not move to POS_END due to ajax mode
Affected Issues
15368
mod - assets/packages/questions/ranking/scripts/ranking.js Diff File

Issue History

Date Modified Username Field Change
2019-10-04 16:59 DenisChenu New Issue
2019-10-04 16:59 DenisChenu File Added: limesurvey_survey_RankingFilterSamePage.lss
2019-10-06 10:55 DenisChenu Assigned To => ollehar
2019-10-06 10:55 DenisChenu Status new => assigned
2019-10-06 10:56 DenisChenu Assigned To ollehar =>
2019-10-06 10:56 DenisChenu Status assigned => new
2019-10-06 10:56 DenisChenu Note Added: 53905
2019-10-06 10:56 DenisChenu Relationship added related to 15369
2019-10-06 10:56 DenisChenu Relationship added related to 15348
2019-10-10 17:13 DenisChenu Assigned To => DenisChenu
2019-10-10 17:13 DenisChenu Status new => assigned
2019-10-10 18:14 DenisChenu Changeset attached => LimeSurvey master af8336f3
2019-10-10 18:14 DenisChenu Note Added: 53993
2019-10-10 18:14 DenisChenu Resolution open => fixed
2019-10-10 18:15 DenisChenu Relationship added related to 15398
2019-10-10 18:15 DenisChenu Status assigned => resolved
2019-10-10 18:15 DenisChenu Fixed in Version => 3.18.x
2019-10-14 13:57 lime_release_bot Note Added: 54030
2019-10-14 13:57 lime_release_bot Status resolved => closed
2019-10-14 15:46 DenisChenu Status closed => resolved
2019-10-14 15:46 DenisChenu Note Added: 54038
2019-10-17 12:01 lime_release_bot Note Added: 54084
2019-10-17 12:01 lime_release_bot Status resolved => closed