View Issue Details

IDProjectCategoryView StatusLast Update
15362Bug reports[All Projects] ComfortUpdatepublic2019-10-04 15:32
ReporterMazi Assigned To 
PrioritynoneSeveritymajor 
Status newResolutionopen 
Product Version3.18.0 
Target VersionFixed in Version 
Summary15362: After updating from LS 3.17.x to 3.18 using ComfortUpdate the "Simple plugins" menu item is missing
Description

At our server as well as at another customer server the "Simple plugins" menu item on the left at survey level is missing. It shows up at other 3.17.x systems at the same server but after using ComfortUpdate to update to 3.18.x the item is gone.
I also tried clearing assets cache at global settings with no luck.

A fresh 3.18 installation set up from scratch does show the menu item.

Additional Information

This is rather urgent since our customer uses various plugins and now can't access their settings.
It probably also affects other users updating to 3.18 using ComfortUpdate.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.18.0+190923
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.2

Activities

Mazi

Mazi

2019-10-04 13:27

partner   ~53881

@c_schmitz, this is a rather serious issue since a customer just updated using COmfortUpdate to get rid of a different issue fixed at a newer release and now they can't access the plugin settings anymore.
Maybe you can include it at the next sprint so we can have a bugfix available next week?

DenisChenu

DenisChenu

2019-10-04 14:48

developer   ~53885

I'm didn't remind when exactly it happen (but before 3.18) but to fix
master/admin/menus/sa/view => reset
/master/admin/menuentries/sa/view => reset



Mazi

Mazi

2019-10-04 15:27

partner   ~53888

Thanks, Denis, that has indeed solved the problem!

It should still be fixed within the core because the mentioned work around leads to losing all menu adjustments.

DenisChenu

DenisChenu

2019-10-04 15:28

developer   ~53889

I think i report it and add the way to add it manually …

DenisChenu

DenisChenu

2019-10-04 15:31

developer   ~53890

https://github.com/LimeSurvey/LimeSurvey/commit/e78be38a0c36176ca7abf6acd00bff98135c6f19#diff-d3f0672bf165da530b05eb1bb3e491ce

DenisChenu

DenisChenu

2019-10-04 15:32

developer   ~53891

maybe it's because "submenu" feature is disable between 3.17 and 3.18 ?

Issue History

Date Modified Username Field Change
2019-10-04 13:25 Mazi New Issue
2019-10-04 13:27 Mazi Note Added: 53881
2019-10-04 14:48 DenisChenu File Added: Capture d’écran du 2019-10-04 14-47-53.png
2019-10-04 14:48 DenisChenu File Added: Capture d’écran du 2019-10-04 14-48-23.png
2019-10-04 14:48 DenisChenu Note Added: 53885
2019-10-04 15:27 Mazi Note Added: 53888
2019-10-04 15:28 DenisChenu Note Added: 53889
2019-10-04 15:31 DenisChenu Note Added: 53890
2019-10-04 15:32 DenisChenu Note Added: 53891