View Issue Details

IDProjectCategoryView StatusLast Update
15352Bug reports[All Projects] Survey participants (Tokens)public2019-11-26 17:32
Reporterluberm Assigned Tocdorin  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.18.0 
Target VersionFixed in Version 
Summary15352: On self-registration X-surveyid & X-tokenid are not set on self-registration email sent-out
Description

When sending survey invitations, LimeSurvey doesn't appear to include X-survey* headers in the emails.

Comparison between my local instance:
X-Mailer: PHPMailer 6.0.7 (https://github.com/PHPMailer/PHPMailer)
X-Surveymailer: surveys Emailer (LimeSurvey.org)
MIME-Version: 1.0

And a free LS.org instance:
X-Mailer: PHPMailer 6.0.7 (https://github.com/PHPMailer/PHPMailer)
X-surveyid: 12345
X-tokenid: Oumfrugza0Ll5as
X-did: 151151
X-Surveymailer: LimeSurvey Professional - Your online survey service Emailer
(LimeSurvey.org)
MIME-Version: 1.0

since both are on 3.18.0 it might be possible this is a database issue? I'm using Postgresql 10.

Steps To Reproduce

Create a new closed active survey, enable self-registration, self-register, check the headers of the email with the survey participation link

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.18.0
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionPostgres 10
Server OS (if known)Linux
Webserver software & version (if known)nginx
PHP Version7.3

Activities

DenisChenu

DenisChenu

2019-10-09 10:42

developer   ~53958

Plugins ?

luberm

luberm

2019-10-09 10:48

reporter   ~53959

No plugins used. All vanilla.

luberm

luberm

2019-10-09 11:14

reporter   ~53960

Alright, while playing a little bit more with it, I figured out, that this appears to only happen when participants register.

So, when sending invitations and reminders through the admin panel, the token and survey-id get properly included in the headers.

So this issue appears to only happen at registration. At least we can rule out my smtp server mangling headers.

Anything that can be done about this?

DenisChenu

DenisChenu

2019-10-09 11:17

developer   ~53961

I think it's already fixed in 4.0 …

But the issue is «Survey register didn't set header for bounce tracking»

luberm

luberm

2019-10-09 11:35

reporter   ~53962

DenisChenu: right.

I fixed it locally for now, by adding:

$customheaders = array('1' => "X-surveyid: ".$iSurveyId, '2' => "X-tokenid: ".$sToken);

and modyfing SendEmailMessage to include $customheaders as additional parameter.

I'll add a PR.

c_schmitz

c_schmitz

2019-11-04 08:39

administrator   ~54379

Link to PR?

luberm

luberm

2019-11-04 11:02

reporter   ~54389

https://github.com/LimeSurvey/LimeSurvey/pull/1329

luberm

luberm

2019-11-26 12:35

reporter   ~54783

This issue is fixed as of https://github.com/LimeSurvey/LimeSurvey/commit/0cf514100f9b79b13023c67cb3827753e230be26

Issue History

Date Modified Username Field Change
2019-10-02 09:39 luberm New Issue
2019-10-09 10:42 DenisChenu Note Added: 53958
2019-10-09 10:48 luberm Note Added: 53959
2019-10-09 11:14 luberm Note Added: 53960
2019-10-09 11:17 DenisChenu Note Added: 53961
2019-10-09 11:35 luberm Note Added: 53962
2019-11-04 08:38 c_schmitz Summary LimeSurvey doesn't set X-surveyid, X-tokenid, X-did headers for bounce tracking on my LS local instance => On self-registration X-surveyid & X-tokenid are not set on self-registration email sent-out
2019-11-04 08:38 c_schmitz Steps to Reproduce Updated View Revisions
2019-11-04 08:39 c_schmitz Note Added: 54379
2019-11-04 11:02 luberm Note Added: 54389
2019-11-26 12:35 luberm Note Added: 54783
2019-11-26 17:32 cdorin Assigned To => cdorin
2019-11-26 17:32 cdorin Status new => closed
2019-11-26 17:32 cdorin Resolution open => fixed