View Issue Details

IDProjectCategoryView StatusLast Update
15134Bug reports[All Projects] Survey designpublic2019-08-08 22:04
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version4.0.0-RC2 
Target VersionFixed in Version4.0.0-RC3 
Summary15134: Quick add : add 2 times the same
Description

Current quick add feature include the current answers (and subquestion)
Then click on Add : you add it 2 times

Steps To Reproduce

See screencast

Additional Information

Update ; to , or \t delete all values.

Then i think there are 2 possible correction

  1. Show quick add like before : all empty and leave Add/replace buttons
  2. Show the quick add feature like 4.0.0RC2 but then must
    a. Allow update ; to , without deleting value (just replace)
    b. Remove the Add buttons
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0 github
I will donate to the project if issue is resolvedNo
BrowserFF
Database & DB-Versionnot relevant?
Server OS (if known)not relevant ?
Webserver software & version (if known)not relevant ?
PHP Versionnot relevant ?

Activities

DenisChenu

DenisChenu

2019-08-05 17:15

developer  

simplescreenrecorder-2019-08-05_17.11.57.webm (428,589 bytes)
markusfluer

markusfluer

2019-08-08 17:34

administrator   ~53157

The bug with the resetting of the delimiter has already been fixed.

And we talked about this internally, the fact that the current questions are shown is on purpose.
This is, a.e. when you want to copy the content to another question without creating a label set prior.

Deleting it is a small step and fairly easy.

DenisChenu

DenisChenu

2019-08-08 22:04

developer   ~53158

Then i think there are 2 possible correction
Remove the Add buttons

Since we already have current answers in quick edit : we must not leave Add button :)

Issue History

Date Modified Username Field Change
2019-08-05 17:15 DenisChenu New Issue
2019-08-05 17:15 DenisChenu File Added: simplescreenrecorder-2019-08-05_17.11.57.webm
2019-08-08 17:29 cdorin Assigned To => markusfluer
2019-08-08 17:29 cdorin Status new => assigned
2019-08-08 17:34 markusfluer Status assigned => resolved
2019-08-08 17:34 markusfluer Resolution open => fixed
2019-08-08 17:34 markusfluer Fixed in Version => 4.0.0-RC3
2019-08-08 17:34 markusfluer Note Added: 53157
2019-08-08 22:04 DenisChenu Note Added: 53158