View Issue Details

IDProjectCategoryView StatusLast Update
15070Bug reports[All Projects] Survey editingpublic2019-11-20 11:10
Reporterandre_ars Assigned Tocdorin  
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version4.0.0-RC1 
Target VersionFixed in Version 
Summary15070: cannot reorder matrix subquestions awnsers
Description

sub questions answers appear in the wrong order and cannot reorder them

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-RC1+190722
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-VersionMariaDB 10.2
Server OS (if known)Centos
Webserver software & version (if known)apache
PHP Version7.2

Activities

cdorin

cdorin

2019-07-26 16:37

manager   ~53026

Hello @andre_ars. Have you tried RC2? I cannot reproduce your error on my instance

andre_ars

andre_ars

2019-07-30 01:21

reporter   ~53039

Upgraded to RC2.

I still can reproduce the problem on one survey.

Creating a new survey the problem doesn't occur.

cdorin

cdorin

2019-08-27 14:52

manager   ~53301

I will test it again once RC4 is released.

Seems better at the moment (using dev branch)

cdorin

cdorin

2019-09-23 09:47

manager   ~53674

Cannot reproduce it anymore. Please wait for the release of RC4 and test it again. Thank you for your inputs!

andre_ars

andre_ars

2019-11-20 10:04

reporter   ~54701

sory for the long delay, but I've been trying to figure out why the function "delete_participants" isn't working at 100% since version 3.14
I'm now at 3.20.2 version (in dev enviroment) and I'm going to use a "confortupdate" to 4.0.0-RC8 (191118).

andre_ars

andre_ars

2019-11-20 11:10

reporter   ~54704

So..
after some failed db upgrades:
CDbCommand falhou ao executar o comando SQL: SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'question' at row 39539
(It seems we have some questions with too large strings.. the query "SELECT MAX(LENGTH(question)) FROM lime_questions" returned: 663024!

The "500: Internal Server Error"
A propriedade "Question.groups" não está definida => The properties "Questions.groups" is not defined

upgraded from 359 to 423

(and the "delete_participants" also isn't working has it was in 3.14)

Issue History

Date Modified Username Field Change
2019-07-24 00:25 andre_ars New Issue
2019-07-26 16:37 cdorin Assigned To => cdorin
2019-07-26 16:37 cdorin Status new => feedback
2019-07-26 16:37 cdorin Note Added: 53026
2019-07-30 01:21 andre_ars Note Added: 53039
2019-07-30 01:21 andre_ars Status feedback => assigned
2019-08-27 14:52 cdorin Note Added: 53301
2019-09-23 09:47 cdorin Status assigned => resolved
2019-09-23 09:47 cdorin Resolution open => fixed
2019-09-23 09:47 cdorin Note Added: 53674
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2019-11-20 10:04 andre_ars Note Added: 54701
2019-11-20 11:10 andre_ars Note Added: 54704