View Issue Details

IDProjectCategoryView StatusLast Update
15057Bug reportsTranslationpublic2019-11-14 21:41
Reporterdavebostockgmail Assigned Tocdorin  
PrioritynoneSeveritypartial_block 
Status assignedResolutionopen 
Product Version3.17.x 
Summary15057: Translation screen not working correctly when there are long question text
Description

The quick translation screen does not render correctly with long question text. I have questions that include long scripts and these are causing the screen to enter quick translations to be displayed in a way that is unworkable with the target language box being too small and the original text box taking over all the screen see images attached.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.7+190627
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL
Server OS (if known)Ubuntu
Webserver software & version (if known)Apache
PHP Version7.2

Activities

davebostockgmail

davebostockgmail

2019-07-18 08:30

reporter  

image1.PNG (49,327 bytes)   
image1.PNG (49,327 bytes)   
image2.PNG (26,583 bytes)   
image2.PNG (26,583 bytes)   
DenisChenu

DenisChenu

2019-07-18 08:33

developer   ~52919

Can you provide a sample lss with only this group and question (you copy your broken survey and delete all not related group)

davebostockgmail

davebostockgmail

2019-07-18 09:08

reporter   ~52920

Here is part of the survey where the Quick Translation seems to go wrong .. I have removed all the other parts of the survey (it is very long) and the failure occurs with these 2 groups.

part.lss (426,128 bytes)
DenisChenu

DenisChenu

2019-07-18 09:21

developer   ~52921

Maybe we need to totally remove all tag ?
At minimum : filter it :)

davebostockgmail

davebostockgmail

2019-07-18 15:27

reporter   ~52925

I have found out what the issue is with this ... it is that the screen is controlled by the length of the question text.

I had an equation question in there with a lot of conditions ...
Q2=If(Q1_A=="Y",1,if(Q1_B=="Y",2 ....... if(Q1_Z=="Y",26}}}}}}}}}} etc.

This seems to have been interpreted as one word and there was no split to adjust the screen size in term of columns... adding in a newline in the source code has corrected the issue.

DenisChenu

DenisChenu

2019-07-19 08:40

developer   ~52926

Yes :). But still need to be fixed ;)

Issue History

Date Modified Username Field Change
2019-07-18 08:30 davebostockgmail New Issue
2019-07-18 08:30 davebostockgmail File Added: image1.PNG
2019-07-18 08:30 davebostockgmail File Added: image2.PNG
2019-07-18 08:33 DenisChenu Note Added: 52919
2019-07-18 09:08 davebostockgmail File Added: part.lss
2019-07-18 09:08 davebostockgmail Note Added: 52920
2019-07-18 09:21 DenisChenu Status new => confirmed
2019-07-18 09:21 DenisChenu Note Added: 52921
2019-07-18 15:27 davebostockgmail Note Added: 52925
2019-07-19 08:40 DenisChenu Note Added: 52926
2019-11-14 21:41 cdorin Assigned To => cdorin
2019-11-14 21:41 cdorin Status confirmed => assigned