View Issue Details

IDProjectCategoryView StatusLast Update
15045Bug reports[All Projects] Pluginspublic2019-07-15 23:43
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version4.0.0-RC2 
Target VersionFixed in Version4.0.0-RC2 
Summary15045: Unable to activate AuditLog plugin
Description

Receive an error when try to activate AuditLog about ENGINE =

Steps To Reproduce

Scan files,
Install AuditLog : OK
Activate AuditLog : KO

Additional Information

Think it's due to https://github.com/LimeSurvey/LimeSurvey/commit/4f97fb02e96c2526fab1ef6db5e9cc73eebc1943#diff-97384261b8bbf966df16e5ad509922db

Because ENGINE = not set for table plugin ?

I update from old 3.X with old config too.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0 d34a697454
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Activities

DenisChenu

DenisChenu

2019-07-14 16:51

developer  

CDbException.html (25,431 bytes)
DenisChenu

DenisChenu

2019-07-14 17:02

developer   ~52870

OK fixed adding mysqlEngine in config-default BUT !

2 way to fix it , unsure of the best

  1. Check if it's empty, didn't set (then get the SQL default one) : https://github.com/LimeSurvey/LimeSurvey/commit/5816d10af42e69e11289d999187133f8fc569ca4#diff-4a95ed4f80f8713aaa18250f998ddfafR150
  2. Add it in config-default : https://github.com/LimeSurvey/LimeSurvey/commit/b4c63a3b55c7fc2f92147c9a30e919eff862ed2c , then previous one never happen …

Can you check ? Can we discuss for the best ?

TonisOrmisson

TonisOrmisson

2019-07-15 20:28

developer   ~52892

I think the config should always provide a value for mysqlengine. I would put this to config-defaults for any fallback cases. But its just form top of my head.

DenisChenu

DenisChenu

2019-07-15 23:43

developer   ~52894

OK, then must partially revert https://github.com/LimeSurvey/LimeSurvey/commit/5816d10af42e69e11289d999187133f8fc569ca4#diff-4a95ed4f80f8713aaa18250f998ddfafR150
Since !empty(Yii::app()->getConfig('mysqlEngine')) is always true

Issue History

Date Modified Username Field Change
2019-07-14 16:51 DenisChenu New Issue
2019-07-14 16:51 DenisChenu Status new => assigned
2019-07-14 16:51 DenisChenu Assigned To => TonisOrmisson
2019-07-14 16:51 DenisChenu File Added: CDbException.html
2019-07-14 16:55 DenisChenu Assigned To TonisOrmisson => DenisChenu
2019-07-14 17:02 DenisChenu Assigned To DenisChenu => TonisOrmisson
2019-07-14 17:02 DenisChenu Status assigned => feedback
2019-07-14 17:02 DenisChenu Note Added: 52870
2019-07-15 20:28 TonisOrmisson Note Added: 52892
2019-07-15 23:43 DenisChenu Note Added: 52894
2019-07-15 23:43 DenisChenu Status feedback => assigned
2019-07-15 23:43 DenisChenu Assigned To TonisOrmisson => DenisChenu
2019-07-15 23:43 DenisChenu Status assigned => resolved
2019-07-15 23:43 DenisChenu Resolution open => fixed
2019-07-15 23:43 DenisChenu Fixed in Version => 4.0.0-RC2