View Issue Details

IDProjectCategoryView StatusLast Update
15006Bug reports[All Projects] Survey designpublic2019-09-23 12:18
Reportermarcgold Assigned ToLouisGac  
PrioritynoneSeveritymajor 
Status confirmedResolutionreopened 
Product Version3.17.x 
Target VersionFixed in Version 
Summary15006: Array Numbers - Checkerbox Display Error
Description

When setting an Array Numbers in Checkerbox format.
The column headings do not display in narrow format screen when the screen layout switches. Displays ok when wider.

This is based on the fruity template, but I have tried this in all templates including stock and it's the same issue.

Tested fully on Chrome Desktop and Mobile (Android & IOS) and Safari IOS.

Steps To Reproduce

Build an array numbers checker-box questions

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.6+190624
I will donate to the project if issue is resolvedNo
BrowserAll
Database & DB-VersionN/A
Server OS (if known)Linux Centos 7
Webserver software & version (if known)Nginx
PHP Version7.2

Relationships

duplicate of 14962 resolvedDenisChenu Checkbox radio Y scale don't shown in little screen 

Activities

marcgold

marcgold

2019-06-26 17:55

reporter  

DenisChenu

DenisChenu

2019-06-26 19:03

developer   ~52572

Version 3.17.6+190624 ?
Fixed here : https://github.com/LimeSurvey/LimeSurvey/commit/5e262a6901848a03430d814bba8e9d55f3a239f9#diff-fbd9719c3b6c1b87eefda2ed75d7c560

Can not reproduce with vanilla or bootswatch or fruity (or skelvanilla).

Can you check with included theme ?

marcgold

marcgold

2019-06-29 16:04

reporter   ~52643

Hi Denis

I have confirmed that the my answer_td_checkboxes.twig file are the same as the version on github. But the problem still persists.
I have checked this in Stock fruity and vanilla and the problem is the same. I am attaching the LSS we are using and the screen images.

Hope this helps.



limesurvey_survey_2846.lss (87,326 bytes)
Vanilla.jpg (31,253 bytes)
Vanilla.jpg (31,253 bytes)
Fruity.png (32,442 bytes)
Fruity.png (32,442 bytes)
DenisChenu

DenisChenu

2019-06-30 18:31

developer   ~52644

Maybe reset assets ?

Can you check with array radio too ?
https://github.com/LimeSurvey/LimeSurvey/commit/4a99f4026309ed6fbba58587963dd76d5db09ba5

marcgold

marcgold

2019-07-09 17:45

reporter   ~52816

Hi Denis,

Sorry for delay, I have been away. How do you reset assets?

DenisChenu

DenisChenu

2019-07-09 17:49

developer   ~52817

In global settings : you have a button

marcgold

marcgold

2019-07-09 21:36

reporter   ~52818

Thanks Denis,
Cleared the Cache and spotted an update to v3.17.7+190627 so have applied this too.
Also, cleared cache, cookies and emptied the tmp/assets folder for good measure.

Sadly the problem still persists on a new survey created today. Array Numbers - CheckerBox Display On.

Interestingly: Array Radio (Array by Column) and Array Numbers without setting the CheckerBox Switch do work as they should - so its only when you switch on the checkerbox display.

Hope this helps.



DenisChenu

DenisChenu

2019-07-11 07:36

developer   ~52822

Really don't understand …
Can you check the files at : application/views/survey/questions/answer/arrays/multiflexi/rows/cells/answer_td_checkboxes.twig.

Maybe something related to twig cache ?
If you can : can you check the timestamp of this file ?

Can you send us a link (private mode if needed)

marcgold

marcgold

2019-07-25 13:24

reporter   ~53003

@DenisChenu - I have installed a new copy of LS and this is now working. So I agree this is a cache issue. Its still a problem but I will now investigate this more.

DenisChenu

DenisChenu

2019-07-26 08:50

developer   ~53015

@LouisGac : do you know if Yii cache can produce such error ?
There are a way to force reset all Yii cache after ComfortUpgrade ?

LouisGac

LouisGac

2019-07-26 10:33

manager   ~53019

I don't see any reason why Twig cache would cause this problem.
If nobody else face the problem, I'd rather bet on a serie of wrong manual updates + custom theme. Hard to say.

DenisChenu

DenisChenu

2019-07-26 10:46

developer   ~53020

I don't see any reason why Twig cache would cause this problem.

Twig use file system for caching :) i don't know how and when this cache was updated. I can look, but maybe you already know ;)

LouisGac

LouisGac

2019-07-26 10:49

manager   ~53021

Indeed the twig cache system is famous for being obscure and poorly documented.
Anyway: what we could do is to delete twig cache after an update.

DenisChenu

DenisChenu

2019-07-26 10:52

developer   ~53022

Indeed the twig cache system is famous for being obscure and poorly documented.

lol ! mdr ! pdtr !

Anyway: what we could do is to delete twig cache after an update.

@marcgold : can you just delete tmp/runtime/twig_cache/ content and see if it's OK on the broken system ?

LouisGac

LouisGac

2019-07-26 10:56

manager   ~53023

Also, if the user upload the files from a dev server to a production server, it could be related to this issue:
https://github.com/twigphp/Twig/issues/2498

Btw: you can see the user clearly says that Twig Documentation for the Cache system is incomplete and wrong.
I will check if we're using realtive or absolute path.

DenisChenu

DenisChenu

2019-07-26 11:00

developer   ~53024

Last edited: 2019-07-26 11:01

View 2 revisions

Yes :)

But clearing tmp/runtime/twig_cache/* can be OK. Then we just need to clear one after ComfortUpgrade (and maybe create a command action)

Let's wait for User answer about manually deleting :)

marcgold

marcgold

2019-07-29 20:55

reporter   ~53037

@DenisChenu - You cracked it. Deleting the twig_cache resolved the problem.

LouisGac

LouisGac

2019-07-30 12:48

manager   ~53041

marcgold: could you tell us how did you update? are you updating a local installation, and then pushing your files to a production server via ftp?

marcgold

marcgold

2019-07-30 15:43

reporter   ~53044

@LouisGac - No we always update using the comfort update. We take a backup first just incase. Have always found the comfort update to be very reliable.

LouisGac

LouisGac

2019-07-30 15:50

manager   ~53045

ok thank you. We'll add a "delete twig cache" after update then.

Issue History

Date Modified Username Field Change
2019-06-26 17:55 marcgold New Issue
2019-06-26 17:55 marcgold File Added: Screenshot 2019-06-26 at 16.40.17.png
2019-06-26 17:55 marcgold File Added: Screenshot 2019-06-26 at 16.40.34.png
2019-06-26 19:03 DenisChenu Assigned To => DenisChenu
2019-06-26 19:03 DenisChenu Status new => closed
2019-06-26 19:03 DenisChenu Resolution open => unable to reproduce
2019-06-26 19:03 DenisChenu Note Added: 52572
2019-06-26 19:03 DenisChenu Status closed => feedback
2019-06-26 19:03 DenisChenu Resolution unable to reproduce => reopened
2019-06-26 19:03 DenisChenu Relationship added duplicate of 14962
2019-06-29 16:04 marcgold File Added: limesurvey_survey_2846.lss
2019-06-29 16:04 marcgold File Added: Vanilla.jpg
2019-06-29 16:04 marcgold File Added: Fruity.png
2019-06-29 16:04 marcgold Note Added: 52643
2019-06-29 16:04 marcgold Status feedback => assigned
2019-06-30 18:31 DenisChenu Note Added: 52644
2019-07-09 17:45 marcgold Note Added: 52816
2019-07-09 17:49 DenisChenu Note Added: 52817
2019-07-09 21:36 marcgold File Added: Screenshot 2019-07-09 at 20.20.34.png
2019-07-09 21:36 marcgold File Added: Screenshot 2019-07-09 at 20.30.48.png
2019-07-09 21:36 marcgold File Added: Screenshot 2019-07-09 at 20.32.36.png
2019-07-09 21:36 marcgold Note Added: 52818
2019-07-11 07:36 DenisChenu Note Added: 52822
2019-07-15 12:21 DenisChenu Status assigned => feedback
2019-07-25 13:24 marcgold Note Added: 53003
2019-07-25 13:24 marcgold Status feedback => assigned
2019-07-26 08:50 DenisChenu Assigned To DenisChenu => LouisGac
2019-07-26 08:50 DenisChenu Status assigned => acknowledged
2019-07-26 08:50 DenisChenu Note Added: 53015
2019-07-26 10:33 LouisGac Note Added: 53019
2019-07-26 10:46 DenisChenu Note Added: 53020
2019-07-26 10:49 LouisGac Note Added: 53021
2019-07-26 10:52 DenisChenu Note Added: 53022
2019-07-26 10:56 LouisGac Note Added: 53023
2019-07-26 11:00 DenisChenu Note Added: 53024
2019-07-26 11:01 DenisChenu Note Edited: 53024 View Revisions
2019-07-29 20:55 marcgold Note Added: 53037
2019-07-30 12:48 LouisGac Note Added: 53041
2019-07-30 15:43 marcgold Note Added: 53044
2019-07-30 15:50 LouisGac Note Added: 53045
2019-09-23 12:18 c_schmitz Status acknowledged => confirmed