View Issue Details

IDProjectCategoryView StatusLast Update
14949Bug reports[All Projects] Import/Exportpublic2019-06-28 12:27
ReporterMaziAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14949: Token based placeholders are not replaced when creating queXML PDF
Description

If you are exporting a survey response as queXML PDF document, the placeholder for {TOKEN:FIRSTNAME} or {TOKEN:ATTRIBUTE_X} are not replaced properly, see attached sample PDF.

Steps To Reproduce
  1. Import the attached LSS file
  2. Create a dummy user with token attribute details
  3. Run the survey, you may want to switch to all-in-one mode first
  4. Use the queXML export feature at the print answers screen to create the PDF
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.1+190408
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2

Relationships

related to 14896 closedmarkusfluer Placeholders missing for texts available at "Data policy settings" 

Activities

Mazi

Mazi

2019-05-29 08:53

partner  

limesurvey_survey_869541_queXML_issue.lss (309,130 bytes)
queXML_PDF.png (153,758 bytes)
Mazi

Mazi

2019-05-29 08:58

partner   ~52139

@c_schmitz, this is for the same customer as https://bugs.limesurvey.org/view.php?id=14896 for which it was planned to provide a new bugfix release last Thursday. Unfortunately, that wasn't done. So can we fix these two shortly to include the fixes at the next release?
It is a long term customer and they had planned to switch to LS 3 this month but the need those fixes because they can't update that often. For any questions please ping me on Skype or Telegram.

dominikvitt

dominikvitt

2019-06-03 15:25

developer   ~52274

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.
https://github.com/LimeSurvey/LimeSurvey/commit/3d8dfd0b5a5e1b607f6641a85b33c6872eb3f530

c_schmitz

c_schmitz

2019-06-03 17:03

administrator   ~52278

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28976

c_schmitz

c_schmitz

2019-06-28 12:27

administrator   ~52641

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29037

Related Changesets

LimeSurvey: master 3d8dfd0b

2019-06-03 15:22:35

Dominik Vitt

Details Diff
Fixed issue 14949: Token based placeholders are not replaced when creating queXML PDF Affected Issues
14949
mod - application/helpers/export_helper.php Diff File

LimeSurvey: master 6f2d32c2

2019-06-04 11:47:41

Dominik Vitt

Details Diff
Fixed issue 14949: Token based placeholders are not replaced when creating queXML PDF - another fix Affected Issues
14949
mod - application/helpers/export_helper.php Diff File

Issue History

Date Modified Username Field Change
2019-05-29 08:53 Mazi New Issue
2019-05-29 08:53 Mazi File Added: limesurvey_survey_869541_queXML_issue.lss
2019-05-29 08:53 Mazi File Added: queXML_PDF.png
2019-05-29 08:58 Mazi Note Added: 52139
2019-05-29 08:59 Mazi Relationship added related to 14896
2019-05-31 13:26 dominikvitt Assigned To => dominikvitt
2019-05-31 13:26 dominikvitt Status new => assigned
2019-06-03 15:25 dominikvitt Status assigned => resolved
2019-06-03 15:25 dominikvitt Resolution open => fixed
2019-06-03 15:25 dominikvitt Fixed in Version => 3.17.x
2019-06-03 15:25 dominikvitt Note Added: 52274
2019-06-03 17:03 Changeset attached => LimeSurvey master 3d8dfd0b
2019-06-03 17:03 c_schmitz Note Added: 52278
2019-06-28 12:27 Changeset attached => LimeSurvey master 6f2d32c2
2019-06-28 12:27 c_schmitz Note Added: 52641