View Issue Details

IDProjectCategoryView StatusLast Update
14945Bug reports[All Projects] RemoteControlpublic2019-11-20 11:22
Reportersomeuser99 Assigned Todominikvitt  
PrioritynoneSeveritymajor 
Status resolvedResolutionunable to reproduce 
Product Version3.17.x 
Target VersionFixed in Version 
Summary14945: delete_participant fails to delete and gives no error back
Description

When trying to delete participants using RPC, i get an empty array back along with error = null.

example from postman:

Post made:

{
"method": "delete_participants",
"params": {
"sSessionKey" : "LI_3IT00FvLyl~hscSVE7vnHTKuBJu9D",
"iSurveyId" : 795957,
"aTokenIds" : ["998877"]
},
"id": 1
}

Result:
{"id":1,"result":{"998877":"Invalid token ID"},"error":null}

Steps To Reproduce

1) Make a new user and give it rights to delete participants.

2) Add some participants.

3) Try deleting the participants. An empty array is received as a result.

Additional Information

The same problem is also posted on the forum: https://www.limesurvey.org/community/forums/development/118501-delete_participants-in-rpc#184928

I tried the audit plugin solution described here but it does not work for me:
https://bugs.limesurvey.org/view.php?id=14601#c51064

Tagsremote control
Complete LimeSurvey version number (& build)Version 3.17.3+190429
I will donate to the project if issue is resolvedYes
Browser
Database & DB-VersionMariaDB 5.5.60
Server OS (if known)CentOS Linux release 7.6.1810 (Core)
Webserver software & version (if known)
PHP Version7

Relationships

related to 14601 new AutitLog : RemoteControl delete_participant tries to execute invalid SQL 

Activities

someuser99

someuser99

2019-05-28 16:34

reporter   ~52133

survey.lss file



limesurvey_survey_795957(1).lss (182,313 bytes)
someuser99

someuser99

2019-05-28 16:35

reporter  

no_result.png (42,620 bytes)
no_result.png (42,620 bytes)
someuser99

someuser99

2019-05-28 16:35

reporter  

permissions.png (87,134 bytes)
permissions.png (87,134 bytes)
someuser99

someuser99

2019-05-28 16:35

reporter  

plugins.png (81,222 bytes)
plugins.png (81,222 bytes)
someuser99

someuser99

2019-05-28 16:39

reporter   ~52134

The above 3 images also describe the problem. I have tried to make a java call as well as from postman.

I also tried with token id with the array brackets and also without strings. I also tried making the calls with key,value pairs.

dominikvitt

dominikvitt

2019-06-04 17:25

developer   ~52299

I just tried to reproduce this issue, but it is working as expected.
There are two points that you need to correct.

  1. Problem is in the syntax you are using.
    Don't use quotes around square brackets.
    Use one of this formats for aTokenIds:
    [123]
    or
    ["123"]

  2. aTokenIds should be Token ID, not Token.
    When you open "Survey participants" page, Token ID is in the first column from the left.

andre_ars

andre_ars

2019-11-20 11:22

reporter   ~54705

Sorry but I have the same issue
My post:
{"method":"delete_participants","params":["xxxxxxxxxxxxxxxxxxxxxxxxxxx","884387",["120"]],"id":1}
this works in 3.14
I've tested to the 3.20.2 and 4.0.8 all with the same error:
a) It doesn't get back a response
b) Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 1' at line 1

Issue History

Date Modified Username Field Change
2019-05-28 16:31 someuser99 New Issue
2019-05-28 16:33 someuser99 Tag Attached: remote control
2019-05-28 16:34 someuser99 File Added: limesurvey_survey_795957(1).lss
2019-05-28 16:34 someuser99 Note Added: 52133
2019-05-28 16:35 someuser99 File Added: no_result.png
2019-05-28 16:35 someuser99 File Added: permissions.png
2019-05-28 16:35 someuser99 File Added: plugins.png
2019-05-28 16:39 someuser99 Note Added: 52134
2019-05-29 11:16 DenisChenu Relationship added related to 14601
2019-05-31 13:29 dominikvitt Assigned To => dominikvitt
2019-05-31 13:29 dominikvitt Status new => assigned
2019-06-04 17:25 dominikvitt Status assigned => resolved
2019-06-04 17:25 dominikvitt Resolution open => unable to reproduce
2019-06-04 17:25 dominikvitt Note Added: 52299
2019-11-20 11:22 andre_ars Note Added: 54705