View Issue Details

IDProjectCategoryView StatusLast Update
14887Bug reports_ Unknownpublic2021-03-08 19:36
ReporterDialogs Assigned ToDenisChenu  
PrioritylowSeveritypartial_block 
Status closedResolutionfixed 
Product Version3.17.x 
Fixed in Version3.25.17 
Summary14887: Groupe de questionnaire innaccessible pour les gestionnaires autres que super admin
DescriptionLes administrateurs de questionnaires qui n'ont pas les droits "super admin" peuvent uniquement choisir le "default survey group" comme groupe de questionnaire dans les paramètres généraux d'un questionnaire. Les autres groupes sont inaccessibles. Ils sont uniquement accessibles pour les "super admin".
Steps To ReproduceCréer des groupes de questionnaires personnalisés avec un user "super admin" et tenter de configurer le groupe de questionnaire avec un gestionnaire de questionnaire n'étant pas "super admin".
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.3+190429
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmysql
Server OS (if known)
Webserver software & version (if known)
PHP Version7.0.32

Activities

Dialogs

Dialogs

2019-06-04 01:50

reporter   ~52283

Bug toujours présent sur 3.17.4 (190529).
DenisChenu

DenisChenu

2019-06-06 07:44

developer   ~52308

Seems to be only if seocnd user didn't have right on all survey dropdown.

I check : create an user with rights on only 2 survey : one in a group and one in another group :
1. Dropdown for group is empty in list
2. In survey listing : can see 'Groups tab' and click on edit and see the 2 groups where he have right
    1. Can edit group settings (???? : i think it's a bad situation)
3. In Survey edition : Group list is empty

@LouisGac : for 3.X proposition
1. Global Survey right => Group right
     1. User with all surveys view can see all groups
     2. User with all surveys edit can edit all groups
     3. User with all surveys delete can delete all groups
2. User with no global surveys right
     1. See (in all list) only the group where he already have a survey

OK ?
@Extract can do the pull request.
DenisChenu

DenisChenu

2021-02-08 20:46

developer   ~62049

Fixed in 4.4

Issue History

Date Modified Username Field Change
2019-05-10 16:11 Dialogs New Issue
2019-06-04 01:50 Dialogs Note Added: 52283
2019-06-06 07:44 DenisChenu Note Added: 52308
2019-11-26 17:53 cdorin Assigned To => cdorin
2019-11-26 17:53 cdorin Status new => assigned
2021-02-08 17:06 cdorin Assigned To cdorin =>
2021-02-08 17:06 cdorin Priority none => low
2021-02-08 17:06 cdorin Status assigned => acknowledged
2021-02-08 20:46 DenisChenu Note Added: 62049
2021-02-08 20:46 DenisChenu Assigned To => DenisChenu
2021-02-08 20:46 DenisChenu Status acknowledged => resolved
2021-02-08 20:46 DenisChenu Resolution open => fixed
2021-02-08 20:46 DenisChenu Fixed in Version => 4.4.0-RC2
2021-03-08 19:36 c_schmitz Fixed in Version 4.4.0-RC2 => 3.25.17
2021-03-08 19:36 c_schmitz Status resolved => closed