View Issue Details

IDProjectCategoryView StatusLast Update
14840Bug reports[All Projects] Survey participants (Tokens)public2019-05-10 15:36
Reporterdominikvitt Assigned Todominikvitt  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0dev 
Target Version4.0.0-betaFixed in Version4.0.0dev 
Summary14840: Unable to assign empty email address using token batch edit
Description

When using token batch edit to assign empty email address, validation message is shown: "Invalid email address."

Steps To Reproduce

Open Survey participants page.
Select one or more tokens.
Choose "Batch-edit participants" from bottom dropdown.
Select "Email" checkbox without entering email address value.

Additional Information

@DenisChenu:
I think problem is in validateAddress method in core/LimeMailer.php, that is a reason why I assign this issue to you.
Empty email address value is set to "lskeep", but this method doesn't recognize it as empty.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-alpha
I will donate to the project if issue is resolvedNo
BrowserChromium, Firefox
Database & DB-VersionMySQL 5.7.24-0ubuntu0.18.04.1
Server OS (if known)Linux Mint 19.2 Tara 64-bit
Webserver software & version (if known)Nginx
PHP Version7.2.17-1+ubuntu18.04.1+deb.sury.org+3

Activities

dominikvitt

dominikvitt

2019-05-02 17:35

developer  

DenisChenu

DenisChenu

2019-05-03 08:25

developer   ~51745

OK,

I'm unsure of moving validateEmail to LimeMailer is a good idea :), but i didn't update the function in fact ?

in master too : https://github.com/LimeSurvey/LimeSurvey/blob/a873e84392f69bfc6af95809f07a1c6a245a084f/application/helpers/common_helper.php#L1248 same function send false for lskeep, no ?

dominikvitt

dominikvitt

2019-05-03 10:22

developer   ~51749

Yes, I thought that you would know what is the issue, but since you don't know, I'll continue with this issue.

DenisChenu

DenisChenu

2019-05-03 10:52

developer   ~51752

I can keep it (but not today i think)

dominikvitt

dominikvitt

2019-05-03 12:40

developer   ~51754

https://github.com/LimeSurvey/LimeSurvey/commit/b2c7014cd0ff6f30bd8445eacf7a58df935ee36b

c_schmitz

c_schmitz

2019-05-10 15:36

administrator   ~51875

4.0beta1 released

Issue History

Date Modified Username Field Change
2019-05-02 17:35 dominikvitt New Issue
2019-05-02 17:35 dominikvitt Status new => assigned
2019-05-02 17:35 dominikvitt Assigned To => DenisChenu
2019-05-02 17:35 dominikvitt File Added: Screenshot_2019-05-02_17-31-01.png
2019-05-03 08:25 DenisChenu Note Added: 51745
2019-05-03 10:22 dominikvitt Note Added: 51749
2019-05-03 10:22 dominikvitt Assigned To DenisChenu => dominikvitt
2019-05-03 10:52 DenisChenu Note Added: 51752
2019-05-03 12:40 dominikvitt Status assigned => resolved
2019-05-03 12:40 dominikvitt Resolution open => fixed
2019-05-03 12:40 dominikvitt Fixed in Version => 4.0.0dev
2019-05-03 12:40 dominikvitt Note Added: 51754
2019-05-10 15:36 c_schmitz Note Added: 51875
2019-05-10 15:36 c_schmitz Status resolved => closed