View Issue Details

IDProjectCategoryView StatusLast Update
14833Bug reports[All Projects] Survey editingpublic2019-05-08 12:26
ReporterDemetra Assigned Todominikvitt  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14833: Default values in List (radio) question does not work
Description

when I set a default value in a List (radio) question I get this error when answering the questionnaire:
"1 is an invalid value for this question", and the chioice is not checked

Activating the debub level 2 I get the attached file.

For what I've understood the problem is that when "checkValidityAnswer" is called in em_manager_helper.php:6949
the variabile $qInfo is not as expected (it doen't have info as index), while the same function is called in the right way here: em_manager_helper.php:8952

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.2+190408
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionPostgresql 10
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2

Relationships

related to 14776 closeddominikvitt Hidden Questions Not Being Asked 

Issue History

Date Modified Username Field Change
2019-05-02 12:46 Demetra New Issue
2019-05-02 12:46 Demetra File Added: PHP notice.html
2019-05-03 17:05 DenisChenu Note Added: 51765
2019-05-08 12:25 DenisChenu Assigned To => dominikvitt
2019-05-08 12:25 DenisChenu Status new => closed
2019-05-08 12:25 DenisChenu Resolution open => fixed
2019-05-08 12:25 DenisChenu Fixed in Version => 3.17.x
2019-05-08 12:25 DenisChenu Note Added: 51825
2019-05-08 12:26 DenisChenu Relationship added related to 14776
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing