View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
14822Bug reportsSurvey editingpublic2019-07-11 14:20
ReporterDenisChenu Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0dev 
Fixed in Version4.0.0-RC2 
Summary14822: Survey text : unable to edit (js broken) debug at 0
Description

When try to editing Survey text (1st time) : js broken

Steps To Reproduce

Survey listing
Click on a survey
Click an Edit text element

Additional Information
TypeError: t[e] is undefined[En savoir plus] lstextelements.js:1:517
    i http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    668d http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    i http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    0 http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    i http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    n http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    <anonyme> http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1
    <anonyme> http://limesurvey.local/develop/tmp/assets/22b2f520/build.min/js/lstextelements.js:1

reload page or click on save : text editor open without js issue.

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)4.0.0 github 4f97fb02e9
I will donate to the project if issue is resolvedNo
BrowserFF 66
Database type & versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Relationships

related to 14821 closedp_teichmann JS console error : DataTable is undefined (debug at 2) 
related to 14755 closedmarkusfluer Experimental editor is empty 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2019-04-30 08:45

developer  

cdorin

cdorin

2019-07-11 12:02

manager   ~52826

Can't reproduce it in RC1. Is it ok now Denis?

DenisChenu

DenisChenu

2019-07-11 14:20

developer   ~52830

yep

Issue History

Date Modified Username Field Change
2019-04-30 08:45 DenisChenu New Issue
2019-04-30 08:45 DenisChenu File Added: Capture d’écran du 2019-04-30 08-43-27.png
2019-04-30 08:46 DenisChenu Relationship added related to 14821
2019-04-30 08:46 DenisChenu Relationship added related to 14755
2019-07-11 12:02 cdorin Assigned To => cdorin
2019-07-11 12:02 cdorin Status new => feedback
2019-07-11 12:02 cdorin Note Added: 52826
2019-07-11 14:20 DenisChenu Status feedback => closed
2019-07-11 14:20 DenisChenu Resolution open => fixed
2019-07-11 14:20 DenisChenu Fixed in Version => 4.0.0-RC2
2019-07-11 14:20 DenisChenu Note Added: 52830
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing