View Issue Details

IDProjectCategoryView StatusLast Update
14724Bug reports[All Projects] Survey takingpublic2019-04-05 11:37
ReportertpartnerAssigned Totpartner 
PrioritynoneSeveritycrash 
Status resolvedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version 
Summary14724: Cannot disable AJAX in the survey theme options
Description

Since updating to 3.16.1, I cannot disable AJAX in the survey theme options.

Selecting AJAX Mode = No has no effect, the pages are still loaded via AJAX.

To me, this is a critical bug as it destroys many JavaScript workarounds.

Steps To Reproduce

1) Upload the attached survey and ensure that AJAX Mode = No.

2) Preview the survey.

3) On the first page load, you will get an alert indicating page load and a new date will be appended to the Q1 question text.

4) Advance to group 2 - the page is loaded via AJAX where it should be a complete page reload.

5) Return to group 1.

6) There is no alert indicating a page load and a second date is inserted below the first. If AJAX were disabled (causing complete page load), there would only be one date inserted!

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.1
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12-dev
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Activities

tpartner

tpartner

2019-04-02 19:40

developer  

capture_3.png (6,427 bytes)
capture_3.png (6,427 bytes)
capture_2.png (14,752 bytes)
capture_2.png (14,752 bytes)
DenisChenu

DenisChenu

2019-04-03 02:01

developer   ~51289

An idea ?
Include https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla in core : no ajax, better a11y, bootswatch variation

;)

DenisChenu

DenisChenu

2019-04-03 11:11

developer   ~51296

@tpartner : lack of lss here ?

tpartner

tpartner

2019-04-03 13:18

developer   ~51303

@DenisChenu, yes, thanks for SkelVanilla.

Sorry, here is the .lss.



limesurvey_survey_461462.lss (14,759 bytes)
DenisChenu

DenisChenu

2019-04-03 13:26

developer   ~51305

Last edited: 2019-04-03 13:31

View 4 revisions

Sorry @tpartner i can not reproduce on 3.17.0 … did you update something other ? debug is at 0 or 2 ?
Maybe fixed between 3.16.1 and 3.17.0

[edit]
Test with ajax mode on : i have the alert the 1st time, not with previous, and string are added.
[edit]
But why date is all the same ? It append and update previous one … really strange …

tpartner

tpartner

2019-04-03 13:49

developer   ~51306

I initially tested with debug = 1.

I have now tested in 3.17.0 and the problem still occurs when debug is 1 or 2, not when debug is 0.

When debug is 1 or 2 and AJAX mode is set to "No" and you return to the first group via the "Previous" button, the alert does not occur and a second (or third...) date string is added. This indicates that the page was not completely reloaded - the $(document).on('ready',function(){} is not fired.

As to why the dates are all the same, as far as I can see, this is (another) bug with the AJAX implemented.

DenisChenu

DenisChenu

2019-04-03 14:09

developer   ~51307

debug at 2 : https://demo.sondages.me/461462

Did you have force_xmlsettings_for_survey_rendering in your config (it happen only with debug > 0)

tpartner

tpartner

2019-04-03 14:16

developer   ~51308

Yes, I did have force_xmlsettings_for_survey_rendering = true.

Testing with that removed works fine - the AJAX mode setting is respected.

So, bug?

DenisChenu

DenisChenu

2019-04-03 14:26

developer   ~51309

Not a bug : you force to get the config from xml, and in xml : it's true …
Solution : extend vanilla, update config.xml for your default needed

tpartner

tpartner

2019-04-03 14:41

developer   ~51314

Okay, thanks for your help.

Mazi

Mazi

2019-04-05 08:51

partner   ~51357

How about disabling Ajax mode by default at the config.xml of all shipped templates?
See https://bugs.limesurvey.org/view.php?id=14616...

tpartner

tpartner

2019-04-05 11:37

developer   ~51375

@Mazi, +1

Issue History

Date Modified Username Field Change
2019-04-02 19:40 tpartner New Issue
2019-04-02 19:40 tpartner File Added: capture_3.png
2019-04-02 19:40 tpartner File Added: capture_2.png
2019-04-03 02:01 DenisChenu Note Added: 51289
2019-04-03 11:11 DenisChenu Note Added: 51296
2019-04-03 13:18 tpartner File Added: limesurvey_survey_461462.lss
2019-04-03 13:18 tpartner Note Added: 51303
2019-04-03 13:26 DenisChenu Note Added: 51305
2019-04-03 13:27 DenisChenu Note Edited: 51305 View Revisions
2019-04-03 13:29 DenisChenu Note Edited: 51305 View Revisions
2019-04-03 13:31 DenisChenu Note Edited: 51305 View Revisions
2019-04-03 13:49 tpartner Note Added: 51306
2019-04-03 14:09 DenisChenu Note Added: 51307
2019-04-03 14:16 tpartner Note Added: 51308
2019-04-03 14:26 DenisChenu Note Added: 51309
2019-04-03 14:41 tpartner Note Added: 51314
2019-04-03 14:41 tpartner Assigned To => tpartner
2019-04-03 14:41 tpartner Status new => resolved
2019-04-03 14:41 tpartner Resolution open => fixed
2019-04-05 08:51 Mazi Note Added: 51357
2019-04-05 11:37 tpartner Note Added: 51375