View Issue Details

IDProjectCategoryView StatusLast Update
14716Bug reports[All Projects] Conditionspublic2019-04-02 16:43
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.17.x 
Summary14716: Participant attribute tab shwon in condition editor for anonymized survey
Description

With anonymized survey : TOKEN: can not be used, but it still shown in GUI condition editor

Steps To Reproduce

Import included survey, open GUI condition edito

Additional Information

Think best is shown a warning since the GUI editor can be used before set survey to not anonymous.

I already fix the information on View (since it broke with https://bugs.limesurvey.org/view.php?id=14714#c51265 (on token and on another variable)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 14714 closedDenisChenu Condition based on TOKEN ATTRIBUTE still not working also with LS 3.16.1+ 
related to 14719 new Expression Manager show valid TOKEN:attribute in anonymized survey 

Issue History

Date Modified Username Field Change
2019-04-02 12:54 DenisChenu New Issue
2019-04-02 12:54 DenisChenu Status new => assigned
2019-04-02 12:54 DenisChenu Assigned To => DenisChenu
2019-04-02 13:16 DenisChenu Status assigned => resolved
2019-04-02 13:16 DenisChenu Resolution open => fixed
2019-04-02 13:16 DenisChenu Fixed in Version => 3.16.x
2019-04-02 13:16 DenisChenu Note Added: 51273
2019-04-02 13:16 DenisChenu Relationship added related to 14714
2019-04-02 13:21 DenisChenu Relationship added related to 14719
2019-04-02 16:43 ollehar Status resolved => closed
2019-04-02 16:43 ollehar Fixed in Version 3.16.x => 3.17.x