View Issue Details

IDProjectCategoryView StatusLast Update
14692Bug reports[All Projects] Survey designpublic2019-04-02 16:42
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.17.x 
Summary14692: CDbException when testing survey
Description

There are CDbException when previewing survey

Steps To Reproduce

Go to a question page on a brower tab
Go to question managing on other
Start a survey (to fill $_SESSION['survey_'.$surveyid]['srid'])
Deactivate survey on question managing
Go to question tab
Preview question or group

Additional Information

I think there are 3 potential issues

  1. $_SESSION['survey_'.$surveyid] is not resetted when survey is deactivate
  2. Preview group or question must NEVER use existing $_SESSION['survey_'.$surveyid]['srid'] even if survey is activated
  3. Before try to get Response : this must test if survey is activated

It's strange because i think we already fix all of this a long time before.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Issue History

Date Modified Username Field Change
2019-03-26 18:30 DenisChenu New Issue
2019-03-26 18:30 DenisChenu File Added: CDbException.html
2019-03-30 19:45 DenisChenu Assigned To => DenisChenu
2019-03-30 19:45 DenisChenu Status new => assigned
2019-03-30 19:46 DenisChenu Status assigned => resolved
2019-03-30 19:46 DenisChenu Resolution open => fixed
2019-03-30 19:46 DenisChenu Note Added: 51223
2019-04-02 16:42 ollehar Status resolved => closed
2019-04-02 16:42 ollehar Fixed in Version => 3.17.x