View Issue Details

IDProjectCategoryView StatusLast Update
14641Bug reports[All Projects] Data Entry (non public)public2019-03-14 10:22
ReporterroutardAssigned Todominikvitt 
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version 
Summary14641: Error when copying a survey to create a new one
Description

Hi!
There is some errors when I want to copy an old survey to create a new one. I joined the question (lsq file).
The copy is Ok except for this question. The question text is copied but the answers options are not copied!
I my case, two of the answers text contain a simple quote (')... I wonder if this is not the same problem as a previous bug I've just noticed, see:
https://bugs.limesurvey.org/view.php?id=14572
Maybe an issue with special quotes not correctly escaped?

Steps To Reproduce

Create a survey with the joined question. The copy the survey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.16.0+190225
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database & DB-Versionmysqlnd 5.0.12-dev
Server OS (if known)Linux webm777.mp.ha.ovh.net 4.14.66-ovh-vps-grsec-zfs-classid #1 SMP Thu Aug 23 15:15:40 CEST 2018 x86_64
Webserver software & version (if known)Apache
PHP Version7.2.14

Activities

routard

routard

2019-03-13 10:32

reporter  

limesurvey_question_8980.lsq (3,114 bytes)
dominikvitt

dominikvitt

2019-03-13 16:25

developer   ~50952

Can't reproduce this issue, it works as expected for me.
If you can reproduce it once more, please send .lss export files, one created before joining question and one after joining.

routard

routard

2019-03-13 17:28

reporter   ~50962

Oups... my mistake (but the translation is confusing). When copiing a survey from an old one, you have the option "Exclude answers". That's not that clear; I thought it was the answers of the participants!!! But in fact it is the answer options (in case of a 'List' question).

dominikvitt

dominikvitt

2019-03-13 17:56

developer   ~50965

So this issue can be closed?

routard

routard

2019-03-13 18:39

reporter   ~50968

Sure!
Sorry for opening this ticket for nothing! Thx again.

Issue History

Date Modified Username Field Change
2019-03-13 10:32 routard New Issue
2019-03-13 10:32 routard File Added: limesurvey_question_8980.lsq
2019-03-13 16:25 dominikvitt Note Added: 50952
2019-03-13 17:28 routard Note Added: 50962
2019-03-13 17:56 dominikvitt Note Added: 50965
2019-03-13 18:39 routard Note Added: 50968
2019-03-14 10:22 dominikvitt Assigned To => dominikvitt
2019-03-14 10:22 dominikvitt Status new => closed
2019-03-14 10:22 dominikvitt Resolution open => fixed