View Issue Details

IDProjectCategoryView StatusLast Update
14640Bug reports[All Projects] Documentationpublic2019-03-13 10:49
ReportergslinesAssigned Tocdorin 
PrioritynoneSeveritymajor 
Status closedResolutionno change required 
Product Version3.16.x 
Target VersionFixed in Version 
Summary14640: Mandatory ranking question with max value forces to rank all options (more than max)
Description

If a value for "Maximum answers" is set for a mandatory ranking questions, participants are still forced to rank all the answer options. (Total answer options > Maximum answers).

Steps To Reproduce
  1. Create a mandatory ranking question with N answer options, and set "Maximum answers" to M, where M < N.

  2. Preview survey and rank M or less answer options. You are not allowed to rank more than M, which is correct

  3. After clicking Next/Submit, a validation error shows saying "One or more mandatory questions have not been answered. You cannot proceed until these have been completed". The ranking question is highlighted and the tip shows " Please rank all items."

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.16.0+190225
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome 72.0.3626.121 (64-bit), Firefox 65.0.1 (64-bit)
Database & DB-Versionmysql Ver 14.14 Distrib 5.7.24, for Linux (x86_64), dbversionnumber = 356
Server OS (if known)CentOS 6-10
Webserver software & version (if known)Apache 2.4
PHP Version7.2

Activities

DenisChenu

DenisChenu

2019-03-13 08:41

developer   ~50938

Just updated manual (since we have a lot of report about this).

With ranking question type : set mandatory to on mean ranking all answers. You can use minimum answers settings if you need to force one answer to be ranked.

https://manual.limesurvey.org/Question_type_-_Ranking#Mandatory

@cdorin : i let you correct my english and validate ?

cdorin

cdorin

2019-03-13 10:49

manager   ~50942

Hey @DenisChenu. On it. it will be done in the next 30 mins.

Issue History

Date Modified Username Field Change
2019-03-12 21:45 gslines New Issue
2019-03-13 08:41 DenisChenu Note Added: 50938
2019-03-13 08:41 DenisChenu Category Survey design => Documentation
2019-03-13 08:42 DenisChenu Assigned To => cdorin
2019-03-13 08:42 DenisChenu Status new => closed
2019-03-13 08:42 DenisChenu Resolution open => no change required
2019-03-13 10:49 cdorin Note Added: 50942