View Issue Details

IDProjectCategoryView StatusLast Update
14628Bug reports[All Projects] Print Viewpublic2019-04-30 09:12
ReporterMaziAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.16.x 
Summary14628: Array numbers question type doesn't include proper subquestion and answer details at "print answers" overview
Description

The "Array numbers" question only shows the item codes at the print answers output, see screenshot. Instead at least subquestion text should be shown. Maybe also replace answer codes by answer texts, otherwise it may be difficult to determine which details a number refers to.
Check attached logic file and compare with the output (screenshot).

Steps To Reproduce

Add an "Array Numbers" question.
Enable "Print answers" feature.
Activate, add some answers and go to "Print answers" link at the end of the survey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.9+190214
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.0.26

Relationships

related to 14520 assignededdylackmann Lots of styles for "print answers" view are hardcoded within Twig files which makes adjusting the page design pretty difficult 

Activities

Mazi

Mazi

2019-03-11 16:22

partner  

array_numbers_print.png (15,413 bytes)
array_numbers_print.png (15,413 bytes)
dominikvitt

dominikvitt

2019-03-13 15:46

developer   ~50948

This issue is fixed only partially.
Answer text is placed in front of answer code on Y axis.
Headers texts on X-axis are not changed because they are not readily available there.
If headers text change is still needed, can be fixed afterwards.

https://github.com/LimeSurvey/LimeSurvey/commit/df50b2367069c978d0b161df4afb29eea656cadf

c_schmitz

c_schmitz

2019-04-30 09:12

administrator   ~51669

Fixed in Version 3.1.7.3

Issue History

Date Modified Username Field Change
2019-03-11 16:22 Mazi New Issue
2019-03-11 16:22 Mazi Status new => assigned
2019-03-11 16:22 Mazi Assigned To => dominikvitt
2019-03-11 16:22 Mazi File Added: array_numbers_logic_file.png
2019-03-11 16:22 Mazi File Added: array_numbers_print.png
2019-03-11 16:23 Mazi Relationship added related to 14520
2019-03-13 15:46 dominikvitt Status assigned => resolved
2019-03-13 15:46 dominikvitt Resolution open => fixed
2019-03-13 15:46 dominikvitt Fixed in Version => 3.16.x
2019-03-13 15:46 dominikvitt Note Added: 50948
2019-04-30 09:12 c_schmitz Note Added: 51669
2019-04-30 09:12 c_schmitz Status resolved => closed