View Issue Details

IDProjectCategoryView StatusLast Update
14608Feature requests[All Projects] Survey participants (Tokens)public2019-03-06 14:58
ReporterWeltN24 Assigned To 
PrioritynoneSeverityfeature 
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary14608: Mandatory fields/attributes in Open Registration
Description

Open registration provide the fiels/attributes "email", "first name" and "name". Only "email" is mandatory. How can i make "first name" and "name" mandatory too.

TagsNo tags attached.

Activities

cdorin

cdorin

2019-03-06 13:35

manager   ~50792

Last edited: 2019-03-06 13:37

View 2 revisions

Hello WeltN24,

Regarding what you wish to do, if it is not a bug, ask your question also on the forum.

As a solution for you, you need to play with your theme. Extend fruity. Screen: Registration -> select register_form.twig. See what is different between participants email and the other two fields (you need to add to the previous two fields <<'required' : true >>).

WeltN24

WeltN24

2019-03-06 14:56

reporter   ~50796

Thank you, that worked. Additional to " <<'required' : true >>" you have to add "{{ include('./subviews/registration/required.twig') }}" into the label.

cdorin

cdorin

2019-03-06 14:58

manager   ~50799

Glad to hear this. Perhaps I will add it into the manual (general faq) soon. Thanks also for your feedback! I will mark it as closed

Issue History

Date Modified Username Field Change
2019-03-06 09:55 WeltN24 New Issue
2019-03-06 13:35 cdorin Note Added: 50792
2019-03-06 13:37 cdorin Note Edited: 50792 View Revisions
2019-03-06 13:37 cdorin Status new => feedback
2019-03-06 14:56 WeltN24 Note Added: 50796
2019-03-06 14:56 WeltN24 Status feedback => new
2019-03-06 14:58 cdorin Status new => closed
2019-03-06 14:58 cdorin Note Added: 50799