View Issue Details

IDProjectCategoryView StatusLast Update
14545Bug reports[All Projects] Menu systempublic2019-04-30 09:11
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14545: Unable to reset menu entries with MSSQL
Description

When trying to reset menu entries : nothing happen

Steps To Reproduce

Click on reset menu entries

Additional Information

Even with switchMSSQLIdentityInsert : it's still an issue

CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Explicit value must be specified for identity column in table 'lime_surveymenu_entries' either when IDENTITY_INSERT is set to ONor when a replication user is inserting into a NOT FOR REPLICATION identity column..
The SQL statement executed was: INSERT INTO [lime_surveymenu_entries] ([menu_id], [user_id], [ordering], [name], [title], [menu_title], [menu_description], [menu_icon], [menu_icon_type], [menu_class], [menu_link], [action], [template], [partial], [classes], [permission], [permission_grade], [data], [getdatamethod], [language], [active], [changed_at], [changed_by], [created_at], [created_by], [showincollapse]) VALUES (:menu_id, :user_id, :ordering, :name, :title, :menu_title, :menu_description, :menu_icon, :menu_icon_type, :menu_class, :menu_link, :action, :template, :partial, :classes, :permission, :permission_grade, :data, :getdatamethod, :language, :active, :changed_at, :changed_by, :created_at, :created_by, :showincollapse) (E:\WebSite\limesurvey\framework\db\CDbCommand.php:358)</p><pre>#0 E:\WebSite\limesurvey\framework\db\CDbCommand.php(1278): CDbCommand->execute(Array)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.9 github
I will donate to the project if issue is resolvedNo
BrowserFF
Database & DB-VersionMS SQL Server 2012
Server OS (if known)windows
Webserver software & version (if known)IIS
PHP Versionphp7

Relationships

related to 13904 closedc_schmitz Japanese characters get replaced with '?' 

Activities

DenisChenu

DenisChenu

2019-02-19 09:14

developer  

image001.png (238,467 bytes)
DenisChenu

DenisChenu

2019-02-19 09:19

developer   ~50614

We don't need switchMSSQLIdentityInsert since id is not set in default now …

DenisChenu

DenisChenu

2019-02-19 09:28

developer   ~50615

https://github.com/LimeSurvey/LimeSurvey/commit/b34bb31def3e26d0ae84f61b5196f1032a5ba67b

Issue History

Date Modified Username Field Change
2019-02-19 09:14 DenisChenu New Issue
2019-02-19 09:14 DenisChenu Status new => assigned
2019-02-19 09:14 DenisChenu Assigned To => markusfluer
2019-02-19 09:14 DenisChenu File Added: image001.png
2019-02-19 09:19 DenisChenu Note Added: 50614
2019-02-19 09:19 DenisChenu Assigned To markusfluer => DenisChenu
2019-02-19 09:28 DenisChenu Status assigned => resolved
2019-02-19 09:28 DenisChenu Resolution open => fixed
2019-02-19 09:28 DenisChenu Fixed in Version => 3.15.x
2019-02-19 09:28 DenisChenu Note Added: 50615
2019-02-19 09:28 DenisChenu Relationship added related to 13904
2019-04-30 09:11 c_schmitz Status resolved => closed
2019-09-10 11:46 c_schmitz Category MenuSystem => Menu system