View Issue Details

IDProjectCategoryView StatusLast Update
14530Bug reportsOtherpublic2021-05-10 15:10
Reportercdorin Assigned Toc_schmitz  
PrioritylowSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.25.12 
Summary14530: Pop-up store password on firefox when I click on some buttons
DescriptionA pop-up is displayed by firefox to store my password for limesurvey whenever I access my global configuration and I click on:
- Save
- Save and close
- Calculate storage

I was also able to reproduce it in 2.73
TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Activities

jelo

jelo

2019-02-15 15:32

partner   ~50573

What Firefox version running on what OS?
cdorin

cdorin

2019-02-15 16:05

manager   ~50574

Last edited: 2019-02-15 16:05

View 2 revisions

Sorry for not providing all the details. Thought it applies to all the firefox installations.

My installation:
- Firefox 65.0
- Ubuntu 18.04

DenisChenu

DenisChenu

2019-02-15 16:40

developer   ~50576

Yes, 2.6lts too … due to smtp and imap password …
very hard to fix …
cdorin

cdorin

2019-02-15 17:25

manager   ~50580

Don t find it urgent since not that many users access the global configuration (at least according to the bugs tracker + forum posts). I will just mark it as confirmed with low priority.
jelo

jelo

2019-02-15 17:37

partner   ~50581

Why should it apply to all Firefox installations (versions)? Seems to be a better sensing / feature of the browser. Firefox 67 will offer an improved new password manager. Perhaps 65 already contain some changes.

LimeSurvey might can rearrange the forms with password, to prevent too many trigger.
DenisChenu

DenisChenu

2019-02-16 00:47

developer   ~50582

«LimeSurvey might can rearrange the forms with password, to prevent too many trigger.» Already try with clean HTML

Except with a lot of worakround JS : no real solution.
c_schmitz

c_schmitz

2021-05-10 10:24

administrator   ~64312

Hello cdorin,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

c_schmitz
DenisChenu

DenisChenu

2021-05-10 10:42

developer   ~64314

Last edited: 2021-05-10 10:43

View 2 revisions

Firefox 88.0

Way to reproduce

1. Go to Global settings
2. Set Bounce settings to imap
3. Enter anything in user/pass and server
4: Save & Close
5: See the little popup

Same behaviour for SMTP with password.

Happen each time you update a value currently (Firefox version dependant ?)
c_schmitz

c_schmitz

2021-05-10 15:10

administrator   ~64325

Ah ok.

It is only when I change something on that particular tab and it is completely normal behaviour because Firefox thinks it is a password field (which it is).
The reporter originally reported it to happen whenever he enters global settings, which it does not (anymore).

Issue History

Date Modified Username Field Change
2019-02-14 18:02 cdorin New Issue
2019-02-15 15:32 jelo Note Added: 50573
2019-02-15 16:05 cdorin Note Added: 50574
2019-02-15 16:05 cdorin Note Edited: 50574 View Revisions
2019-02-15 16:40 DenisChenu Note Added: 50576
2019-02-15 17:25 cdorin Note Added: 50580
2019-02-15 17:26 cdorin Priority none => low
2019-02-15 17:26 cdorin Status new => confirmed
2019-02-15 17:37 jelo Note Added: 50581
2019-02-16 00:47 DenisChenu Note Added: 50582
2021-02-25 19:06 ollehar Target Version => 3.22.13
2021-02-25 19:07 ollehar Product Version => 3.25.12
2021-02-25 19:07 ollehar Target Version 3.22.13 =>
2021-05-10 10:24 c_schmitz Assigned To => c_schmitz
2021-05-10 10:24 c_schmitz Status confirmed => closed
2021-05-10 10:24 c_schmitz Resolution open => fixed
2021-05-10 10:24 c_schmitz Note Added: 64312
2021-05-10 10:42 DenisChenu Status closed => feedback
2021-05-10 10:42 DenisChenu Resolution fixed => reopened
2021-05-10 10:42 DenisChenu Note Added: 64314
2021-05-10 10:43 DenisChenu Note Edited: 64314 View Revisions
2021-05-10 15:10 c_schmitz Note Added: 64325
2021-05-10 15:10 c_schmitz Status feedback => closed
2021-05-10 15:10 c_schmitz Resolution reopened => unable to reproduce