View Issue Details

IDProjectCategoryView StatusLast Update
14497Bug reports[All Projects] Authenticationpublic2019-02-07 13:37
ReporterpoehlmanAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status resolvedResolutionunable to reproduce 
Product Version3.15.x 
Target VersionFixed in Version 
Summary14497: Survey Administrators spontaneously lost their permissions
Description

Dear Support-Team,

this morning I received a complaint by a survey administrator that she could no longer login into the admin interface to administer the user responses for her survey.
Indeed, she had lost all permissions to deal with the survey (internal database authentication). I then also checked for other survey administrators: same picture meaning everybody lost access to administer his/her own survey.

Any idea what have caused this behaviour? NO changes regarding user perimission applied from my side.

Only side note, however not the slightest clue if this is of any relevance in this context:
the survey of question had 03-Feb set as expiry date and was already expired. On 04-Feb, it had been decided to extend it until 06-Feb so I re-activated it and set a new expiry date. But this should not cause a loss in survey administrator permissions ...?!?!

Many thanks in advance for your support.

Best regards,
-Rainer Pöhlmann

Steps To Reproduce

To be honest: not the slightest clue!

Additional Information

Question was:
"Also by survey permissions, you mean global permissions, right? Or did your user lost only the right to authenticate via the internal database authentication mechanism? Are your users part of survey groups or and "global" user groups?"

  • no global user groups existing
  • user were still defined to use internal database authentication but had no permissions assigned at all, so they could login but then apparently saw an empty page.
  • I am referring to "Edit user permissions for user XYZ" which then looked like you can see in attached sceenshot "permissions_disappeared.gif". All before individually assigned permissions vanished.
  • was something like in seen attached screenshot "permissions_before.gif"
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.1 181017
I will donate to the project if issue is resolvedNo
Browserbrowser independant
Database & DB-Version Ver 14.14 Distrib 5.7.25, for Linux (x86_64) using EditLine wrapper
Server OS (if known)CentOS Linux release 7.6.1810 (Core)
Webserver software & version (if known)Apache 2.4.35 OpenSSL/1.0.2k-fips PHP/7.2.10
PHP VersionPHP/7.2.10

Activities

poehlman

poehlman

2019-02-07 10:11

reporter  

permissions_before.gif (16,936 bytes)
permissions_before.gif (16,936 bytes)
dominikvitt

dominikvitt

2019-02-07 13:37

developer   ~50440

I'm unable to reproduce this issue.
I searched existing code base to see if it is possible that some script would do such changes, but there are none.
There is no way to change those settings other than manually removing checkboxes and saving.

Also I examined if survey expiration would have an effect on global permissions, but there is no such connection.

You are using LS version which is now almost 4 months old, so updating to the latest version could also help in solving of this issue.

If you can find a way to reproduce this issue in the future, I would reopen it.

Issue History

Date Modified Username Field Change
2019-02-07 10:11 poehlman New Issue
2019-02-07 10:11 poehlman File Added: permissions_disappeared.gif
2019-02-07 10:11 poehlman File Added: permissions_before.gif
2019-02-07 11:33 dominikvitt Assigned To => dominikvitt
2019-02-07 11:33 dominikvitt Status new => assigned
2019-02-07 13:37 dominikvitt Status assigned => resolved
2019-02-07 13:37 dominikvitt Resolution open => unable to reproduce
2019-02-07 13:37 dominikvitt Note Added: 50440