View Issue Details

IDProjectCategoryView StatusLast Update
14490Bug reports[All Projects] _ Unknownpublic2019-04-30 09:11
Reporterrealitix Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14490: PHP error with Question L on statistic page
Description

Hello,

I found a bug in the statistic computation.
I'm sending the pull request to fix it.

Steps To Reproduce
  1. Import the joined survey (the .lss file)
  2. Activate the survey
  3. Fill some questions with all fields.
    When you select the "Other" field, put a text in the textarea.
  4. Go to statistics
    -> Include all answer
    -> Put all to yes
    -> Select PDF
    -> Show the statistics
    -> Crash:

PHP notice

Undefined offset: 2

/app/application/helpers/admin/statistics_helper.php(2354)

2351 if ($outputs['qtype'] == "P") {
2352 $sColumnName = $al[2]."comment";
2353 } else {
2354 $sColumnName = $al[2];
2355 }

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.8
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionpgsql
Server OS (if known)
Webserver software & version (if known)
PHP Version0

Activities

realitix

realitix

2019-02-04 18:15

reporter  

limesurvey_survey_375455.lss (16,692 bytes)
realitix

realitix

2019-02-04 18:21

reporter   ~50399

Here the pull request: https://github.com/LimeSurvey/LimeSurvey/pull/1212

DenisChenu

DenisChenu

2019-02-04 18:32

developer   ~50400

Strange, fix seems OK, but i can not reproduce … on mariadb



survey_archive_375455.lsa (3,931 bytes)
realitix

realitix

2019-02-05 16:30

reporter   ~50413

You can't reproduce on mariadb because it's like MySQL, very permissive.

DenisChenu

DenisChenu

2019-02-05 17:15

developer   ~50415

Yes, maybe : butg i don't understand why PHP send a notice here with pg and not with mysql ?

Why count($al) is different with mysql and pgsql ?

DenisChenu

DenisChenu

2019-02-06 09:06

developer   ~50418

OK reproduce with pdf or html with pgsl. Still strange :)

DenisChenu

DenisChenu

2019-02-06 09:08

developer   ~50419

Merged

Issue History

Date Modified Username Field Change
2019-02-04 18:15 realitix New Issue
2019-02-04 18:15 realitix File Added: limesurvey_survey_375455.lss
2019-02-04 18:21 realitix Note Added: 50399
2019-02-04 18:32 DenisChenu File Added: survey_archive_375455.lsa
2019-02-04 18:32 DenisChenu Note Added: 50400
2019-02-05 16:30 realitix Note Added: 50413
2019-02-05 17:14 DenisChenu Database & DB-Version 0 => pgsql
2019-02-05 17:15 DenisChenu Note Added: 50415
2019-02-06 09:06 DenisChenu Note Added: 50418
2019-02-06 09:08 DenisChenu Assigned To => DenisChenu
2019-02-06 09:08 DenisChenu Status new => resolved
2019-02-06 09:08 DenisChenu Resolution open => fixed
2019-02-06 09:08 DenisChenu Fixed in Version => 3.15.x
2019-02-06 09:08 DenisChenu Note Added: 50419
2019-04-30 09:11 c_schmitz Status resolved => closed