View Issue Details

IDProjectCategoryView StatusLast Update
14477Bug reports[All Projects] Pluginspublic2019-03-14 17:04
ReporterDenisChenuAssigned To 
PrioritynoneSeverityminor 
Status newResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary14477: LimeSurvey api createUrl didn't use publicurl setting
Description

When using $this->api->createUrl function, and have publicurl set elsewhere: publicurl is not used.
And $paras is required in API, but not in Yii one

Steps To Reproduce

Importincluded plugins
Set publicurl to valid public url
Look at global config of this plugin

Additional Information

2 way to fix:

  1. Move createAbsoluteUrl to controller
  2. return App()->getController()->createAbsoluteUrl
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.8 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2019-01-31 17:50

developer  

publicUrl.zip (1,825 bytes)
DenisChenu

DenisChenu

2019-01-31 17:51

developer   ~50376

PS : currently i never use LimeSurvey api , but always Yii …
PS2: @markusfluer : issue for LimeSAML (i fixed it in oecd fork)

Issue History

Date Modified Username Field Change
2019-01-31 17:50 DenisChenu New Issue
2019-01-31 17:50 DenisChenu File Added: publicUrl.zip
2019-01-31 17:51 DenisChenu Note Added: 50376