View Issue Details

IDProjectCategoryView StatusLast Update
14468Bug reports[All Projects] Otherpublic2019-05-29 16:39
ReporterdanguyfreduxAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.17.x 
Summary14468: Viewing "Surveys in this group" displays all surveys regardless of Survey Group
Description

When viewing the surveys in a survey group, all surveys are displayed rather than just those within that survey group.

Steps To Reproduce

1.) Create a survey group.
2.) Assigned one or more surveys to that survey group, ensuring that one or more surveys remain assigned to the default or another group.
3.) Go to the Survey list.
4.) Select the "Survey groups" tab.
5.) Select the name of the survey group from steps 1-2.
6.) Heading is "Surveys in this group", as expected, but all surveys are displayed.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5+181115
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysql v14.14 distrib 5.5.62-38.14
Server OS (if known)
Webserver software & version (if known)
PHP Version5.6.25

Activities

DenisChenu

DenisChenu

2019-01-31 10:26

developer   ~50354

I think the sentence must be different, what i understand:

  1. See survey in group A : use filter
  2. Manage survey in group A (remove/add from group) : use Survey in this group

I think we must rename Survey inthis group to "Manage survey in this group" or sothing like this.

jelo

jelo

2019-01-31 13:36

partner   ~50361

There were versions of LS3 which didn't displayed all surveys instead only the surveys of the group.

The reporter of this issue is using 3.15.5+181115.
So the reporter might check via demo.limesurvey.org if the issue is there too.

DenisChenu

DenisChenu

2019-01-31 14:14

developer   ~50364

@jelo : i confirm the issue in last GIT version :)
See screenshot



c_schmitz

c_schmitz

2019-05-23 14:54

administrator   ~52080

I can reproduce this, too.

dominikvitt

dominikvitt

2019-05-23 16:44

developer   ~52093

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.
https://github.com/LimeSurvey/LimeSurvey/commit/ffe66a5c0f6ae003611f606a2bddbf709d2cc812

c_schmitz

c_schmitz

2019-05-29 16:12

administrator   ~52169

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28878

c_schmitz

c_schmitz

2019-05-29 16:39

administrator   ~52225

Version 3.17.4+190529 released

Related Changesets

LimeSurvey: master ffe66a5c

2019-05-23 16:41:47

Dominik Vitt

Details Diff
Fixed issue 14468: Viewing "Surveys in this group" displays all surveys regardless of Survey Group Affected Issues
14468
mod - application/models/Survey.php Diff File

Issue History

Date Modified Username Field Change
2019-01-30 15:52 danguyfredux New Issue
2019-01-31 10:26 DenisChenu Note Added: 50354
2019-01-31 10:27 DenisChenu Assigned To => c_schmitz
2019-01-31 10:27 DenisChenu Status new => assigned
2019-01-31 13:36 jelo Note Added: 50361
2019-01-31 14:14 DenisChenu File Added: Capture d’écran du 2019-01-31 14-13-49.png
2019-01-31 14:14 DenisChenu File Added: Capture d’écran du 2019-01-31 14-13-59.png
2019-01-31 14:14 DenisChenu Note Added: 50364
2019-05-23 14:54 c_schmitz Assigned To c_schmitz => dominikvitt
2019-05-23 14:54 c_schmitz Note Added: 52080
2019-05-23 16:44 dominikvitt Status assigned => resolved
2019-05-23 16:44 dominikvitt Resolution open => fixed
2019-05-23 16:44 dominikvitt Fixed in Version => 3.17.x
2019-05-23 16:44 dominikvitt Note Added: 52093
2019-05-29 16:12 Changeset attached => LimeSurvey master ffe66a5c
2019-05-29 16:12 c_schmitz Note Added: 52169
2019-05-29 16:39 c_schmitz Note Added: 52225
2019-05-29 16:39 c_schmitz Status resolved => closed