View Issue Details

IDProjectCategoryView StatusLast Update
14463Bug reports[All Projects] Survey designpublic2019-05-29 15:12
ReporterterryaulenbachAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.14.x 
Target VersionFixed in Version 
Summary14463: Invitation/Reminder file attachments not working
Description

We are having an issue where after adding a file to an invitation (or reminder, etc) email and saving, the HTML editor disappears and the code is shown, and the attachment disappears as well. In related news, when the HTML editor is not showing, clicking on the Add file button simply refreshes the page.

Steps To Reproduce
  1. upload file to the Resources section
  2. go to Email templates and click on the Add file button (Invitation email, Reminder email, etc.)
  3. select your file (you will see it listed - may not be related, but the Size doesn't show, just a dash)
  4. Scroll up and hit the Save button (HTML editor is not a simple text editor, file no longer listed)
  5. Hit the Save button again (HTML editor is back, file is still missing) (Note: if you try the Add file button before hitting Save again, the page simply reloads)
Additional Information

I have also tested this in 3.15.1+181017 on a separate machine, also Windows.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.14.11+180926
I will donate to the project if issue is resolvedNo
Browsermultiple browsers
Database & DB-VersionPostgreSQL 9.6.5 (win32)
Server OS (if known)Windows Server 2012 R2 Standard Edition
Webserver software & version (if known)Apache 2.4.33 (Win64)
PHP VersionPHP 7.2.7 (x64)

Activities

terryaulenbach

terryaulenbach

2019-01-29 17:43

reporter  

after_2nd_save.png (119,732 bytes)
after_save.png (129,499 bytes)
before.png (118,828 bytes)
file_added.png (126,344 bytes)
dominikvitt

dominikvitt

2019-02-08 16:09

developer   ~50473

This issue was fixed a few months ago, so you should update your installation to the latest version.

asshank

asshank

2019-03-19 11:00

reporter   ~51051

There is still an isue.
It goes wrong when lime is installed on a subdomain.
IMHO it is an issue since Lime 2 and upto the current version. (update() function in emailtemplates.php)

In 'application/controllers/admin/emailtemplates.php' the update() function is trying to convert the uploaded file(s) to its URI (url).
When lime is installed on a domain e.g. 'domain.org' it is works.
But if it is installed on 'sub.domain.org' the uploaded file is not to be found by its uri (url) and therefore not saved as an attachment!

But because it is saved on the right spot by kcfinder and kcfinder is finding and displaying the file... I gather that kcfinder is capable of finding the right uri (url)
So… I should mimic/use/copy the function found in kcfinder to determine the url! That will make is work in all circumstances.

dominikvitt

dominikvitt

2019-03-20 14:15

developer   ~51065

I just tried to test this issue using my account on LimeSurvey SAAS hosting on subdomain xxxxxx.limequery.com.
LS version is 3.15.9.
It works as expected, can not reproduce this issue.
Please update to the latest LS version.

terryaulenbach

terryaulenbach

2019-05-27 17:25

reporter   ~52117

I finally got out development server updated to Version 3.17.3+190429. The problem still exists for us.

dominikvitt

dominikvitt

2019-05-29 15:12

developer   ~52161

I just checked again and it works on my local machine.
I guess problem is something with your server configuration.
See if any javascript errors or blocked requests are showed in developer console (F12).

Issue History

Date Modified Username Field Change
2019-01-29 17:43 terryaulenbach New Issue
2019-01-29 17:43 terryaulenbach File Added: after_2nd_save.png
2019-01-29 17:43 terryaulenbach File Added: after_save.png
2019-01-29 17:43 terryaulenbach File Added: before.png
2019-01-29 17:43 terryaulenbach File Added: file_added.png
2019-02-07 16:14 dominikvitt Assigned To => dominikvitt
2019-02-07 16:14 dominikvitt Status new => assigned
2019-02-08 16:09 dominikvitt Status assigned => resolved
2019-02-08 16:09 dominikvitt Resolution open => unable to reproduce
2019-02-08 16:09 dominikvitt Note Added: 50473
2019-03-19 11:00 asshank Note Added: 51051
2019-03-20 14:15 dominikvitt Note Added: 51065
2019-04-30 09:10 c_schmitz Status resolved => closed
2019-05-27 17:25 terryaulenbach Note Added: 52117
2019-05-29 15:12 dominikvitt Note Added: 52161