View Issue Details

IDProjectCategoryView StatusLast Update
14426Bug reports[All Projects] Import/Exportpublic2019-01-17 14:43
ReporterAngelLRAssigned Todominikvitt 
PrioritynoneSeveritycrash 
Status resolvedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14426: Error exporting PDF with graphs
Description

When I export the statistics of a survey to a PDF it works like a charm, but if I enable the option "Show graphs" and try to export it, I get the following error:

"count(): Parameter must be an array or an object that implements Countable"

Additional Information

I am attaching the html page with the error.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.6+190108
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome, Mozilla Firefox, Microsoft Edge
Database & DB-Version?
Server OS (if known)CentOS
Webserver software & version (if known)Apache/2.4.6
PHP Version7.2.12

Relationships

duplicate of 14417 resolveddominikvitt PHP warning on response statistics page when "Show graphs" option is turned on 

Activities

AngelLR

AngelLR

2019-01-14 10:12

reporter  

PHP warning.html (23,141 bytes)
LouisGac

LouisGac

2019-01-17 10:34

manager   ~50250

dominik, can you confirm you fixed this bug?

dominikvitt

dominikvitt

2019-01-17 10:56

developer   ~50252

@LouisGac: I didn't fixed this bug.
I can't reproduce it with error message, but I can see that graph silently fails to load in pdf or Excel file.
So I would try to fix it.

AngelLR

AngelLR

2019-01-17 11:04

reporter   ~50253

The error does not appear if I turn off the debug mode as it is said in https://bugs.limesurvey.org/view.php?id=14417

I guess this happens cause it is a warning so if debug mode is turned off it does not show anything.

guest

guest

2019-01-17 14:32

viewer   ~50255

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28768

Related Changesets

LimeSurvey: master 576c0e84

2019-01-17 14:31:42

Dominik Vitt

Details Diff
Fixed issue 14426: Error exporting PDF with graphs
mod - application/third_party/pchart/pData.class.php Diff File

Issue History

Date Modified Username Field Change
2019-01-14 10:12 AngelLR New Issue
2019-01-14 10:12 AngelLR File Added: PHP warning.html
2019-01-14 12:25 dominikvitt Relationship added duplicate of 14417
2019-01-17 10:33 LouisGac Assigned To => dominikvitt
2019-01-17 10:33 LouisGac Status new => assigned
2019-01-17 10:34 LouisGac Note Added: 50250
2019-01-17 10:56 dominikvitt Note Added: 50252
2019-01-17 11:04 AngelLR Note Added: 50253
2019-01-17 14:32 Changeset attached => LimeSurvey master 576c0e84
2019-01-17 14:32 guest Note Added: 50255
2019-01-17 14:32 guest Resolution open => fixed
2019-01-17 14:43 dominikvitt Status assigned => resolved
2019-01-17 14:43 dominikvitt Fixed in Version => 3.15.x