View Issue Details

IDProjectCategoryView StatusLast Update
14415Bug reports[All Projects] Theme editorpublic2019-04-30 09:11
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14415: Unale to use SAVEDID or some other reponse related var in submit.twig
Description

A client of mine, updating from 1.81 use "Current response : {SAVEDID}" in endmessage.pstpl (or something like this).
I try to use &lt;div class=&quot;text-info&quot;>Numéro enquête : <strong>{{ processString(&quot;{SAVEDID}&quot;) }}</strong>&lt;/div> but : it don't work

Steps To Reproduce

Extend vanilla update submit and put <strong>{{ processString(&quot;{SAVEDID}&quot;) }}</strong>
anywhere

It work only if survey allow print.

Additional Information

I think we just need to move killsession.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 14507 closedDenisChenu Unable to use some needed var in EM twig 

Activities

LouisGac

LouisGac

2019-01-10 15:27

manager   ~50149

theme engine is new in LS3
Please, read this:
https://manual.limesurvey.org/New_Template_System_in_LS3.x

DenisChenu

DenisChenu

2019-01-10 15:30

developer   ~50150

Yes ? And :
In 2.6lts (and surely 2.5X) : you can hack completed.pstpl to show {SAVEDID}
In 3.X : you can't , even using new system {{ processString('{SAVEDID}') }}

There are an issue here …
About SAVEDID : can not fix before 4.0 (need EM update), but it must be fixed …

LouisGac

LouisGac

2019-01-10 15:54

manager   ~50154

sorry, didn't see you was the reporter, I thought about usual complains about retro-compatibility.

DenisChenu

DenisChenu

2019-01-10 16:06

developer   ~50157

It's about retro compat : but not without updating theme/template ;).

I try with
https://bin.shnoulle.net/?eb9cb001c0d38e9e#EMdYT04bSvSFod58mpxxEpPihNIYCNgzt2WwORnWqjU=
(partial)

But need to move Yii::app()->twigRenderer->renderHtmlPage to public.

I can make the pull-request

This fix partially : OK with EM Q00.NAOK etc … but not with SAVEDID because it was in replacements_helper and not in EM.

I think SAVEDID can be moved to EM (like SID and TOKEN:} in 4.0 but not in 3.X

DenisChenu

DenisChenu

2019-01-10 16:10

developer   ~50158

https://github.com/LimeSurvey/LimeSurvey/pull/1206

c_schmitz

c_schmitz

2019-01-22 16:17

administrator   ~50290

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=28782

DenisChenu

DenisChenu

2019-02-08 14:06

developer   ~50461

Last edited: 2019-02-08 14:10

View 2 revisions

Same for TOKEN then SAVEDID : https://www.limesurvey.org/forum/can-i-do-this-with-limesurvey/117616-get-token-in-completed-submit-twig-template#180175

DenisChenu

DenisChenu

2019-02-08 15:16

developer   ~50469

I close this one for end message
I open another one for SAVEDID
https://bugs.limesurvey.org/view.php?id=14507

Related Changesets

LimeSurvey: master 781039c9

2019-01-22 16:17:08

DenisChenu


Committer: c_schmitz Details Diff
Fixed issue 14415: (partial) unable to use Expression Manager var in submit.twig (#1206)

Dev: no SAVEDID, but core EM var (question code etc …)
Affected Issues
14415
mod - application/core/LSETwigViewRenderer.php Diff File
mod - application/helpers/SurveyRuntimeHelper.php Diff File

Issue History

Date Modified Username Field Change
2019-01-09 17:52 DenisChenu New Issue
2019-01-10 15:27 LouisGac Assigned To => LouisGac
2019-01-10 15:27 LouisGac Status new => closed
2019-01-10 15:27 LouisGac Resolution open => won't fix
2019-01-10 15:27 LouisGac Note Added: 50149
2019-01-10 15:30 DenisChenu Status closed => new
2019-01-10 15:30 DenisChenu Resolution won't fix => reopened
2019-01-10 15:30 DenisChenu Note Added: 50150
2019-01-10 15:54 LouisGac Note Added: 50154
2019-01-10 16:06 DenisChenu Note Added: 50157
2019-01-10 16:10 DenisChenu Note Added: 50158
2019-01-10 16:10 DenisChenu Status new => assigned
2019-01-22 16:17 c_schmitz Changeset attached => LimeSurvey master 781039c9
2019-01-22 16:17 c_schmitz Note Added: 50290
2019-01-22 16:17 c_schmitz Assigned To LouisGac => c_schmitz
2019-02-08 14:06 DenisChenu Note Added: 50461
2019-02-08 14:10 DenisChenu Note Edited: 50461 View Revisions
2019-02-08 15:15 DenisChenu Relationship added related to 14507
2019-02-08 15:16 DenisChenu Note Added: 50469
2019-02-08 15:28 DenisChenu Assigned To c_schmitz => DenisChenu
2019-02-08 15:28 DenisChenu Status assigned => resolved
2019-02-08 15:28 DenisChenu Fixed in Version => 3.15.x
2019-04-30 09:11 c_schmitz Status resolved => closed