View Issue Details

IDProjectCategoryView StatusLast Update
14406Bug reports[All Projects] Survey takingpublic2019-01-15 09:27
Reporternh905Assigned ToDenisChenu 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14406: 'Ranking' Question with Computed Answers Is Allocating Insufficient Row Height
Description

I am working on a survey where answers to a 'ranking' question are taken from the responses to an earlier ranking question. Everything worked fine on 3.14.2 but after upgrading to 3.15.5, the text of the computed answers is cut off at the bottom because the rows are not high enough. The computed text is fine - I can read it after I drag it to the answer box, even though the row height is still too small (I only allow one answer, so the answer can spill into the following space. If I use static answers, the row heights are fine. I have attached a screenshot showing the ranking display with computed answers and another one with static answers. I have also attached an export of a demo survey.

I had a look at the generated HTML. The first ranking has three <li> tags with style="height: 0px;". The second ranking question has style="height: 20px;".

The problem occurred with both the Fruity and Vanilla themes.

Steps To Reproduce

Create a ranking question where the answers are computed based on an earlier ranking question.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.5+181115
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmysql Ver 14.14 Distrib 5.5.40
Server OS (if known)CentOS 6
Webserver software & version (if known)Apache 2.2.15
PHP Version5.6.25

Relationships

related to 14410 resolveddominikvitt Ranking : no alert when try to put more than answer 
related to 14411 resolvedDenisChenu Ranking choice height is to big than needed in case of filter 

Activities

nh905

nh905

2019-01-08 15:23

reporter  

surveys_archive.zip (3,918 bytes)
ranking row height.jpg (70,647 bytes)
ranking row height.jpg (70,647 bytes)
DenisChenu

DenisChenu

2019-01-09 08:29

developer   ~50127

OK, semi fixed in 3.15.6 (last version), since moving from height to max-height.
In 3.15.5 : you can disable same choice height and same list height.

DenisChenu

DenisChenu

2019-01-09 09:58

developer   ~50129

https://github.com/LimeSurvey/LimeSurvey/commit/2cb7dee93f899e56802f0f7a57fa6ed67cdec3e1

DenisChenu

DenisChenu

2019-01-15 09:27

developer   ~50203

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=28728

Related Changesets

LimeSurvey: master 2cb7dee9

2019-01-09 09:28:43

DenisChenu

Details Diff
Fixed issue 14406: 'Ranking' Question same choice height not updated when a expression update choice
Dev: udage of html:updated
mod - application/config/version.php Diff File
mod - assets/packages/questions/ranking/scripts/ranking.js Diff File

Issue History

Date Modified Username Field Change
2019-01-08 15:23 nh905 New Issue
2019-01-08 15:23 nh905 File Added: surveys_archive.zip
2019-01-08 15:23 nh905 File Added: ranking row height.jpg
2019-01-09 08:08 DenisChenu Assigned To => DenisChenu
2019-01-09 08:08 DenisChenu Status new => assigned
2019-01-09 08:29 DenisChenu Note Added: 50127
2019-01-09 08:35 DenisChenu Relationship added related to 14410
2019-01-09 09:34 DenisChenu Status assigned => resolved
2019-01-09 09:34 DenisChenu Resolution open => fixed
2019-01-09 09:34 DenisChenu Fixed in Version => 3.15.x
2019-01-09 09:42 DenisChenu Relationship added related to 14411
2019-01-09 09:58 DenisChenu Note Added: 50129
2019-01-15 09:27 DenisChenu Changeset attached => LimeSurvey master 2cb7dee9
2019-01-15 09:27 DenisChenu Note Added: 50203