View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
14373Bug reports_ Unknownpublic2021-09-09 08:59
Reporterlarjona Assigned Togalads  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Summary14373: Tip text in Ranking type questions assumes a particular spatial layout (two columns, left and right)
DescriptionHello
Thanks for developing LimeSurvey.
I have an instance with version 3.15.5+181115 in https://surveys.debian.net and we're using it for a survey about the future Debian release artwork.
The survey consists in one question type Ranking, the options are shown as HTML images (loaded from the original places where the artwork is stored, wiki.debian.org).
The default theme for the question was resulting in a suboptimal layout, so we chose the advanced_ranking theme for this question. This makes the available options appear in a group and at the bottom the other group for the chosen ranking, instead of in two columns (left and right). Then, the help tip becomes confusing, because it reads:
"Double-click or drag-and-drop items in the left list to move them to the right - your highest ranking item should be on the top right, moving through to your lowest ranking item."
but our participants don't see "a right column", they move their chosen options to the bottom, and those are ordered left-to-right.
After receiving several reports about the issue, we have hidden the tip, and added "You can use double-click and drag-and-drop to select/move items." to the question text.

My suggestion is that the help tip does not assume a particular spatial layout (I suppose (but didn't test) that even with the default theme, in small screens as the mobile ones, the page will show groups up-down instead of columns left-right). "You can use double-click and drag-and-drop to select/move items." would be my proposed text but I realise it's not very explicative either...
Steps To ReproduceCreate a survey
Add a question of type "Ranking"
Choose advanced_ranking as theme
Add answer options that include images, or long texts.
Preview question in several screen resolutions (e.g. mobile).

Or go to https://surveys.debian.net and take the survey (if you already vote, showing the question page and abandoning the page later is ok, since you don't need to submit your answers to see the layout issue).

Or unzip the attachment and open the question.html file in a web browser (to see the layout we have).
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)3.15.5+181115
I will donate to the project if issue is resolvedNo
Browserested in Firefox and Chromium in Debian stable)
Database & DB-VersionPostgreSQL from Debian stable
Server OS (if known)Debian 9 stable
Webserver software & version (if known)Nginx from Debian stable
PHP Version7.0 (php7.0-fpm package from Debian stable)

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

larjona

larjona

2018-12-20 15:13

reporter  

question_exporthtml.zip (404,172 bytes)
DenisChenu

DenisChenu

2018-12-20 16:08

developer   ~50053

It's a question theme issue : the string is done only for javascript (check disabling javascript)

https://github.com/LimeSurvey/LimeSurvey/blob/73fe91e1b81657c2f5668ec551e2e6477a637cc1/themes/question/ranking_advanced/survey/questions/answer/ranking/assets/scripts/advanced_ranking.js#L25
DenisChenu

DenisChenu

2018-12-20 16:08

developer  

markusfluer

markusfluer

2018-12-21 22:27

administrator   ~50063

Removing JavaScript will remove the complete ranking functionality desired, that is no option therefore.

I'll have a look to fix the question type. I won't be able to until the first week of January, though.
The help text is rendered in the question type and we can change that depending on what theme is loaded.
ollehar

ollehar

2021-03-10 22:39

administrator   ~63203

Please update to the latest version and check if the bug can still be reproduced. Thank you.
galads

galads

2021-09-09 08:59

administrator   ~66421

Hello larjona,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

galads

Issue History

Date Modified Username Field Change
2018-12-20 15:13 larjona New Issue
2018-12-20 15:13 larjona File Added: question_exporthtml.zip
2018-12-20 16:08 DenisChenu Note Added: 50053
2018-12-20 16:08 DenisChenu Assigned To => markusfluer
2018-12-20 16:08 DenisChenu Status new => assigned
2018-12-20 16:08 DenisChenu File Added: Capture d’écran du 2018-12-20 16-08-39.png
2018-12-21 22:27 markusfluer Note Added: 50063
2021-03-10 22:39 ollehar Assigned To markusfluer =>
2021-03-10 22:39 ollehar Status assigned => feedback
2021-03-10 22:39 ollehar Note Added: 63203
2021-09-09 08:59 galads Assigned To => galads
2021-09-09 08:59 galads Status feedback => closed
2021-09-09 08:59 galads Resolution open => fixed
2021-09-09 08:59 galads Note Added: 66421
2021-09-09 08:59 galads Bug heat 6 => 8