View Issue Details

IDProjectCategoryView StatusLast Update
14354Bug reports[All Projects] Import/Exportpublic2019-04-30 09:11
Reportercharlottej990Assigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionnot fixable 
Product Version3.15.x 
Target VersionFixed in Version 
Summary14354: Date Stamp exports with 1980-01-01 00:00:00 when Date Stamp was not collected
Description

When you create a new survey you can select if you want to collect Date Stamp (its under Notifications & Data).
If you leave this as 'No', you do not want to collect the Date Stamp, and you then export your responses, there is a column for Date Stamp in the exported file and it is populated with 1980-01-01 00:00:00.

Steps To Reproduce

When you create a new survey you can select if you want to collect Date Stamp (its under Notifications & Data).

You leave this as default 'No' setting.

You create the survey & collect responses & create responses/participants tables as needed.

Go to Responses > Export Responses

Select CSV and make sure you have 'all responses' selected so you see data.

Click Export.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.4+181109
I will donate to the project if issue is resolvedNo
BrowserChrome/IE11
Database & DB-VersionmariaDB 10.1
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.12

Activities

charlottej990

charlottej990

2018-12-17 13:16

reporter  

limesurveyexport1980.csv (4,681 bytes)
DenisChenu

DenisChenu

2018-12-19 11:43

developer   ~50004

submitdate is a datetime SQL, need to be a real date time.

alexwinter

alexwinter

2018-12-19 11:57

reporter   ~50005

Hi DenisChenu, do you mean that the submitdate column in the database is not the correct data type? this is the reason it fails to exclude this attribute from the export?

DenisChenu

DenisChenu

2018-12-19 12:09

developer   ~50006

No, it's a datetime SQL type, i don't see any issue here actually.

1980-01-01 mean completed, null/empty mean not completed : not an issue for me.

An export can set it to Y/"" but … I don't care of it. see Y or 1980-01-01 mean "submitted"

alexwinter

alexwinter

2018-12-19 12:55

reporter   ~50007

It would seem to me that the submitdate field is being used incorrectly, if this field is a datetime field it would be incorrect to display that field as a "Y" string

I understand what you are saying, however from a users perspective seeing a datetime of "1980-01-01" is confusing they would not understand the inner workings of the product and would see it as incorrect data.

DenisChenu

DenisChenu

2018-12-19 19:39

developer   ~50014

My point of view

  1. Have 1980 in DB is not an issue : MySQL allow 0000-00-00 00:00:00 but not MSQL and pgSQL if i remind
  2. When export : https://manual.limesurvey.org/Export_responses#Export_to_application_.28Excel.2F.csv.29
    2.A. using Answer code : don't update (except if adding an checkbox)
    2.B. Using Full answers : why not export as gT(Yes), but unsure here …

Issue History

Date Modified Username Field Change
2018-12-17 13:16 charlottej990 New Issue
2018-12-17 13:16 charlottej990 File Added: limesurveyexport1980.csv
2018-12-19 11:43 DenisChenu Note Added: 50004
2018-12-19 11:57 alexwinter Note Added: 50005
2018-12-19 12:09 DenisChenu Note Added: 50006
2018-12-19 12:55 alexwinter Note Added: 50007
2018-12-19 19:39 DenisChenu Note Added: 50014
2019-01-10 16:00 LouisGac Assigned To => LouisGac
2019-01-10 16:00 LouisGac Status new => resolved
2019-01-10 16:00 LouisGac Resolution open => not fixable
2019-04-30 09:11 c_schmitz Status resolved => closed